summaryrefslogtreecommitdiff
path: root/x11-misc/hsetroot/hsetroot-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /x11-misc/hsetroot/hsetroot-1.0.5.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'x11-misc/hsetroot/hsetroot-1.0.5.ebuild')
-rw-r--r--x11-misc/hsetroot/hsetroot-1.0.5.ebuild27
1 files changed, 10 insertions, 17 deletions
diff --git a/x11-misc/hsetroot/hsetroot-1.0.5.ebuild b/x11-misc/hsetroot/hsetroot-1.0.5.ebuild
index cde4912ca941..515cd6e49130 100644
--- a/x11-misc/hsetroot/hsetroot-1.0.5.ebuild
+++ b/x11-misc/hsetroot/hsetroot-1.0.5.ebuild
@@ -2,31 +2,24 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="Tool which allows you to compose wallpapers ('root pixmaps') for X"
HOMEPAGE="https://github.com/himdel/hsetroot/"
-SRC_URI="
- https://github.com/himdel/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
-"
+SRC_URI="https://github.com/himdel/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-RDEPEND="
- >=media-libs/imlib2-1.0.6.2003[X]
+RDEPEND=">=media-libs/imlib2-1.0.6.2003[X]
x11-libs/libX11
- x11-libs/libXinerama
-"
-DEPEND="
- ${RDEPEND}
- x11-base/xorg-proto
-"
-BDEPEND="
- virtual/pkgconfig
-"
-DOCS="AUTHORS ChangeLog NEWS README"
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
PATCHES=(
"${FILESDIR}"/${PN}-1.0.5-XOpenDisplay.patch
)
@@ -52,5 +45,5 @@ src_compile() {
src_install() {
dobin ${PN} hsr-outputs
- dodoc README.md
+ einstalldocs
}