summaryrefslogtreecommitdiff
path: root/x11-misc/habak/habak-0.2.5-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /x11-misc/habak/habak-0.2.5-r3.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'x11-misc/habak/habak-0.2.5-r3.ebuild')
-rw-r--r--x11-misc/habak/habak-0.2.5-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/habak/habak-0.2.5-r3.ebuild b/x11-misc/habak/habak-0.2.5-r3.ebuild
new file mode 100644
index 000000000000..1dcc37e3e714
--- /dev/null
+++ b/x11-misc/habak/habak-0.2.5-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A simple but powerful tool to set desktop wallpaper"
+HOMEPAGE="https://sourceforge.net/projects/fvwm-crystal/"
+SRC_URI="https://sourceforge.net/projects/fvwm-crystal/files/${PN}/${PV}/${P}.tar.gz/download -> ${P}-sourceforge.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ media-libs/imlib2[X]
+ x11-libs/libX11
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+DOCS=( ChangeLog README TODO "${FILESDIR}"/README.en )
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+ emake -C src ${PN}
+}
+
+src_install() {
+ dobin src/${PN}
+ einstalldocs
+}