summaryrefslogtreecommitdiff
path: root/x11-misc/grub2-theme-preview/grub2-theme-preview-1.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /x11-misc/grub2-theme-preview/grub2-theme-preview-1.5.1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'x11-misc/grub2-theme-preview/grub2-theme-preview-1.5.1.ebuild')
-rw-r--r--x11-misc/grub2-theme-preview/grub2-theme-preview-1.5.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/grub2-theme-preview/grub2-theme-preview-1.5.1.ebuild b/x11-misc/grub2-theme-preview/grub2-theme-preview-1.5.1.ebuild
new file mode 100644
index 000000000000..c955b14f2b62
--- /dev/null
+++ b/x11-misc/grub2-theme-preview/grub2-theme-preview-1.5.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Preview a GRUB 2.x theme using KVM/QEMU"
+HOMEPAGE="https://github.com/hartwork/grub2-theme-preview"
+SRC_URI="https://github.com/hartwork/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="grub_platforms_efi-64"
+
+RDEPEND="app-emulation/qemu
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-libs/libisoburn
+ sys-fs/mtools
+ grub_platforms_efi-64? (
+ sys-boot/grub:2[grub_platforms_efi-64]
+ sys-firmware/edk2-ovmf
+ )
+ !grub_platforms_efi-64? (
+ sys-boot/grub:2[grub_platforms_pc]
+ )
+"