summaryrefslogtreecommitdiff
path: root/x11-misc/grsync/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /x11-misc/grsync/files
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'x11-misc/grsync/files')
-rw-r--r--x11-misc/grsync/files/grsync-1.3.0-desktop.patch24
-rw-r--r--x11-misc/grsync/files/grsync-1.3.0-nested_func.patch21
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/grsync/files/grsync-1.3.0-desktop.patch b/x11-misc/grsync/files/grsync-1.3.0-desktop.patch
new file mode 100644
index 000000000000..5cdc49194371
--- /dev/null
+++ b/x11-misc/grsync/files/grsync-1.3.0-desktop.patch
@@ -0,0 +1,24 @@
+diff -Naur grsync-1.3.0.orig/configure.in grsync-1.3.0/configure.in
+--- grsync-1.3.0.orig/configure.in 2020-05-28 10:16:05.000000000 +0200
++++ grsync-1.3.0/configure.in 2020-12-04 09:30:40.082105813 +0100
+@@ -30,7 +30,7 @@
+ GTK_API_VERSION="2.0"
+ fi
+ pkg_modules="gtk+-$GTK_API_VERSION >= 2.16.0"
+-OTHER_DESKTOP_ENTRIES="Icon=grsync.png"
++OTHER_DESKTOP_ENTRIES="Icon=grsync"
+ MIMEINFO_XMLNS="xmlns='http://www.freedesktop.org/standards/shared-mime-info'"
+ MIME_OSSOCAT=""
+
+diff -Naur grsync-1.3.0.orig/grsync.desktop.in grsync-1.3.0/grsync.desktop.in
+--- grsync-1.3.0.orig/grsync.desktop.in 2015-09-11 13:21:28.000000000 +0200
++++ grsync-1.3.0/grsync.desktop.in 2020-12-04 09:30:50.473110946 +0100
+@@ -4,7 +4,7 @@
+ Terminal=false
+ Type=Application
+ MimeType=application/x-grsync-session;
+-Categories=Application;System;
++Categories=System;
+ GenericName=Synchronize files with rsync
+ GenericName[fr]=Interface GTK pour rsync
+ GenericName[it]=Sincronizza file con rsync
diff --git a/x11-misc/grsync/files/grsync-1.3.0-nested_func.patch b/x11-misc/grsync/files/grsync-1.3.0-nested_func.patch
new file mode 100644
index 000000000000..6d135674bac8
--- /dev/null
+++ b/x11-misc/grsync/files/grsync-1.3.0-nested_func.patch
@@ -0,0 +1,21 @@
+diff -Naur grsync-1.3.0.orig/src/callbacks.c grsync-1.3.0/src/callbacks.c
+--- grsync-1.3.0.orig/src/callbacks.c 2020-11-23 14:52:42.000000000 +0100
++++ grsync-1.3.0/src/callbacks.c 2020-12-04 09:18:27.573776667 +0100
+@@ -40,12 +40,12 @@
+ gboolean more = FALSE, first = TRUE;
+
+
+-void dialog_set_labels_selectable(GtkWidget *dialog) {
+- void _set_label_selectable(gpointer data, gpointer user_data) {
+- GtkWidget *widget = GTK_WIDGET(data);
+- if (GTK_IS_LABEL(widget)) gtk_label_set_selectable(GTK_LABEL(widget), TRUE);
+- }
++void _set_label_selectable(gpointer data, gpointer user_data) {
++ GtkWidget *widget = GTK_WIDGET(data);
++ if (GTK_IS_LABEL(widget)) gtk_label_set_selectable(GTK_LABEL(widget), TRUE);
++}
+
++void dialog_set_labels_selectable(GtkWidget *dialog) {
+ GtkWidget *area = gtk_message_dialog_get_message_area(GTK_MESSAGE_DIALOG(dialog));
+ GtkContainer *box = (GtkContainer *) area;
+ GList *children = gtk_container_get_children(box);