summaryrefslogtreecommitdiff
path: root/x11-misc/gmrun/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/gmrun/files
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/gmrun/files')
-rw-r--r--x11-misc/gmrun/files/gmrun-0.9.2-gcc43.patch40
-rw-r--r--x11-misc/gmrun/files/gmrun-0.9.2-glibc210.patch11
-rw-r--r--x11-misc/gmrun/files/gmrun-0.9.2-stlport.patch35
-rw-r--r--x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch41
4 files changed, 127 insertions, 0 deletions
diff --git a/x11-misc/gmrun/files/gmrun-0.9.2-gcc43.patch b/x11-misc/gmrun/files/gmrun-0.9.2-gcc43.patch
new file mode 100644
index 000000000000..e1d4d6d211ac
--- /dev/null
+++ b/x11-misc/gmrun/files/gmrun-0.9.2-gcc43.patch
@@ -0,0 +1,40 @@
+--- a/src/gtkcompletionline.cc
++++ b/src/gtkcompletionline.cc
+@@ -29,6 +29,7 @@
+ #include <set>
+ #include <sstream>
+ #include <string>
++#include <cstring>
+ #include <vector>
+ using namespace std;
+
+--- a/src/ci_string.h
++++ b/src/ci_string.h
+@@ -7,6 +7,7 @@
+ #define __CI_STRING_H__
+
+ #include <string>
++#include <cstring>
+ #include <ctype.h>
+
+ struct ci_char_traits : public std::char_traits<char>
+--- a/src/prefs.cc
++++ b/src/prefs.cc
+@@ -13,6 +13,7 @@
+ #include <fstream>
+ #include <iostream>
+ #include <stdio.h>
++#include <stdlib.h>
+
+ #include <list>
+
+--- a/src/main.cc
++++ b/src/main.cc
+@@ -14,6 +14,7 @@
+ #include <gdk/gdkkeysyms.h>
+
+ #include <string>
++#include <cstring>
+ #include <iostream>
+ #include <sstream>
+ #include <vector>
diff --git a/x11-misc/gmrun/files/gmrun-0.9.2-glibc210.patch b/x11-misc/gmrun/files/gmrun-0.9.2-glibc210.patch
new file mode 100644
index 000000000000..6e12a56f431d
--- /dev/null
+++ b/x11-misc/gmrun/files/gmrun-0.9.2-glibc210.patch
@@ -0,0 +1,11 @@
+--- a/src/gtkcompletionline.cc
++++ b/src/gtkcompletionline.cc
+@@ -376,7 +377,7 @@
+ return 0;
+ }
+
+-int my_alphasort(const void* va, const void* vb) {
++int my_alphasort(const dirent** va, const dirent** vb) {
+ const struct dirent** a = (const struct dirent**)va;
+ const struct dirent** b = (const struct dirent**)vb;
+
diff --git a/x11-misc/gmrun/files/gmrun-0.9.2-stlport.patch b/x11-misc/gmrun/files/gmrun-0.9.2-stlport.patch
new file mode 100644
index 000000000000..426f652a0c2b
--- /dev/null
+++ b/x11-misc/gmrun/files/gmrun-0.9.2-stlport.patch
@@ -0,0 +1,35 @@
+https://bugs.gentoo.org/show_bug.cgi?id=164339
+
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,7 +1,7 @@
+ ## Process this file with automake to produce Makefile.in
+
+ INCLUDES = \
+- @GTK_CFLAGS@ @STLPORT_CXXFLAGS@
++ @GTK_CFLAGS@
+
+ bin_PROGRAMS = gmrun
+
+@@ -13,7 +13,7 @@
+
+ # gmrun_LDFLAGS = -s
+
+-gmrun_LDADD = @GTK_LIBS@ @STLPORT_LDFLAGS@
++gmrun_LDADD = @GTK_LIBS@
+
+ AM_CPPFLAGS = \
+ -DPACKAGE_DATA_DIR='"$(datadir)/$(PACKAGE)"' -DPACKAGE_SYSCONF_DIR='"$(sysconfdir)"'
+--- a/configure.in
++++ b/configure.in
+@@ -37,8 +37,8 @@
+ AC_HEADER_DIRENT
+ AC_HEADER_STDC
+ AC_PROG_CXX
+-AC_PATH_STLPORT_LIB
+-AC_PATH_STLPORT_INC
++dnl REMOVED _LIB
++dnl REMOVED _INC
+
+
+ AC_CHECK_FUNC( poptGetContext,
diff --git a/x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch b/x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch
new file mode 100644
index 000000000000..92db743a8df5
--- /dev/null
+++ b/x11-misc/gmrun/files/gmrun-0.9.2-sysconfdir.patch
@@ -0,0 +1,41 @@
+http://bugs.gentoo.org/292856
+
+--- a/config/Makefile.am
++++ b/config/Makefile.am
+@@ -1,6 +1,6 @@
+ # $Id$
+
+-myrcdir = @PACKAGE_DATA_DIR@
++myrcdir = $(sysconfdir)
+ myrc_DATA = gmrunrc
+
+ EXTRA_DIST = gmrunrc
+--- a/config.h.in
++++ b/config.h.in
+@@ -10,7 +10,6 @@
+ #undef HAVE_STPCPY
+ #undef HAVE_LIBSM
+ #undef PACKAGE_LOCALE_DIR
+-#undef PACKAGE_DATA_DIR
+ #undef PACKAGE_SOURCE_DIR
+
+ /* Define if you have the <dirent.h> header file. */
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -15,3 +15,5 @@
+
+ gmrun_LDADD = @GTK_LIBS@ @STLPORT_LDFLAGS@
+
++AM_CPPFLAGS = \
++ -DPACKAGE_DATA_DIR='"$(datadir)/$(PACKAGE)"' -DPACKAGE_SYSCONF_DIR='"$(sysconfdir)"'
+--- a/src/prefs.cc
++++ b/src/prefs.cc
+@@ -30,7 +30,7 @@
+
+ Prefs::Prefs()
+ {
+- string file_name = PACKAGE_DATA_DIR"/";
++ string file_name = PACKAGE_SYSCONF_DIR"/";
+ file_name += GMRUNRC;
+ init(file_name);
+