summaryrefslogtreecommitdiff
path: root/x11-misc/gccmakedep/gccmakedep-1.0.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /x11-misc/gccmakedep/gccmakedep-1.0.3-r1.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'x11-misc/gccmakedep/gccmakedep-1.0.3-r1.ebuild')
-rw-r--r--x11-misc/gccmakedep/gccmakedep-1.0.3-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/gccmakedep/gccmakedep-1.0.3-r1.ebuild b/x11-misc/gccmakedep/gccmakedep-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..dbd7fd229348
--- /dev/null
+++ b/x11-misc/gccmakedep/gccmakedep-1.0.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="create dependencies in makefiles using 'gcc -M'"
+HOMEPAGE="https://www.x.org/wiki/ https://cgit.freedesktop.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/util/${PN}.git"
+ inherit autotools git-r3
+ # x11-misc/util-macros only required on live ebuilds
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+else
+ SRC_URI="mirror://xorg/util/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ ${LIVE_DEPEND}
+ x11-base/xorg-proto
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ --disable-selective-werror
+ )
+
+ econf "${econfargs[@]}"
+}