summaryrefslogtreecommitdiff
path: root/x11-misc/gammastep
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-06 04:13:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-06 04:13:54 +0000
commit6471b382a951b256ffa1b8ea3e6e7d7f5b189281 (patch)
treebbf20ea2988714b3e374b9766666cc2082972074 /x11-misc/gammastep
parent97975d199eba29b1b2f09f99dcd0566f2d1f581f (diff)
gentoo auto-resync : 06:11:2023 - 04:13:53
Diffstat (limited to 'x11-misc/gammastep')
-rw-r--r--x11-misc/gammastep/Manifest1
-rw-r--r--x11-misc/gammastep/gammastep-2.0.9-r2.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/x11-misc/gammastep/Manifest b/x11-misc/gammastep/Manifest
index fd05bf8d9375..702bb5998293 100644
--- a/x11-misc/gammastep/Manifest
+++ b/x11-misc/gammastep/Manifest
@@ -1,3 +1,4 @@
DIST gammastep-v2.0.9.tar.bz2 540120 BLAKE2B cfc29b157ad2dbd3d6bb0ac4bdb26c958ba07cad3e817931c2ee4c2e4d15c157b7c0b8b891869ddcc2cdfc39c1d52afb8437991ae60501afee84500e1f28c694 SHA512 d8b23e5890d6135cef79057408e1b7c1dbc36444dfbfaf7c80a3f36c46df19eaded1829c2cd52365413779cc752d0911a44669b5abce16d7e266b92b15c035fb
EBUILD gammastep-2.0.9-r1.ebuild 1941 BLAKE2B 7d0040d270cb5818b4f5a39a69db3aee9df9a94ad0a102904748c2fced3bca12a2c9252ab907b3261d7555337140358367e1d345a228b0d3b3229c335f2dc2a0 SHA512 cfe0f5d682c3323b242c6246f07c555dfd8a7d274211ba6e8def4353aed891abf2315547b2541595327cc7f1516f17931ffdd17864487f38cc5a8fc6a4d30d2f
+EBUILD gammastep-2.0.9-r2.ebuild 1942 BLAKE2B 74769a53fd0e4c3835c426f1fe6094b0ce0c0cc8ba3026c43785bdad17a206e6e6f807197721440da8275b9b06627046988646a955147ba594cdd1e64333af04 SHA512 b11f152ec36f5862aa36cda3c76d2552e93563f94ce1697797b079859e548f53149df2b13816e777338526a921cee7272114fd880ddfed21b03146b6630b9aab
MISC metadata.xml 408 BLAKE2B 76e880ceff79cafe0ee71c2b2bab4c2977a43eb15bc2ffb26cf1431b6c9303bd3b95801e501d01134e546e20c0c83239864eb32e4b8bcea0c7eb8191bc191d8b SHA512 dfd49b49ec66241adb4e53941455d4e1df8af068f894748973fcafab0f8e87238fa3d358b222366efb897558dd7f05e67274a11799169470b5ea3d2663b10137
diff --git a/x11-misc/gammastep/gammastep-2.0.9-r2.ebuild b/x11-misc/gammastep/gammastep-2.0.9-r2.ebuild
new file mode 100644
index 000000000000..b5a7e3bc5849
--- /dev/null
+++ b/x11-misc/gammastep/gammastep-2.0.9-r2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit autotools systemd xdg-utils python-r1
+
+DESCRIPTION="A screen color temperature adjusting software"
+HOMEPAGE="https://gitlab.com/chinstrap/gammastep"
+SRC_URI="https://gitlab.com/chinstrap/gammastep/-/archive/v${PV}/gammastep-v${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="appindicator geoclue gtk nls wayland"
+
+COMMON_DEPEND=">=x11-libs/libX11-1.4
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ x11-libs/libdrm
+ appindicator? ( dev-libs/libayatana-appindicator )
+ geoclue? ( app-misc/geoclue:2.0 dev-libs/glib:2 )
+ gtk? ( ${PYTHON_DEPS} )"
+RDEPEND="${COMMON_DEPEND}
+ gtk? ( dev-python/pygobject[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ dev-python/pyxdg[${PYTHON_USEDEP}] )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ nls? ( sys-devel/gettext )
+"
+REQUIRED_USE="gtk? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}"/${PN}-v${PV}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use gtk && python_setup
+
+ econf \
+ $(use_enable nls) \
+ --enable-drm \
+ $(use_enable wayland) \
+ --enable-randr \
+ --enable-vidmode \
+ $(use_enable geoclue geoclue2) \
+ $(use_enable gtk gui) \
+ --enable-apparmor \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+}
+
+_impl_specific_src_install() {
+ emake DESTDIR="${D}" \
+ PYTHON="${PYTHON}" \
+ pythondir="$(python_get_sitedir)" \
+ -C src/gammastep_indicator install
+}
+
+src_install() {
+ emake DESTDIR="${D}" UPDATE_ICON_CACHE=/bin/true install
+
+ if use gtk; then
+ python_foreach_impl _impl_specific_src_install
+ python_replicate_script "${D}"/usr/bin/gammastep-indicator
+
+ python_foreach_impl python_optimize
+ fi
+
+ insinto /etc/gammastep/
+ newins gammastep.conf.sample config.ini.example
+}
+
+pkg_postinst() {
+ use gtk && xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ use gtk && xdg_icon_cache_update
+}