summaryrefslogtreecommitdiff
path: root/x11-misc/fraqtive/fraqtive-0.4.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/fraqtive/fraqtive-0.4.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/fraqtive/fraqtive-0.4.8.ebuild')
-rw-r--r--x11-misc/fraqtive/fraqtive-0.4.8.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/x11-misc/fraqtive/fraqtive-0.4.8.ebuild b/x11-misc/fraqtive/fraqtive-0.4.8.ebuild
new file mode 100644
index 000000000000..5c0a787ab56a
--- /dev/null
+++ b/x11-misc/fraqtive/fraqtive-0.4.8.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils gnome2-utils qmake-utils toolchain-funcs
+
+DESCRIPTION="an open source, multi-platform generator of the Mandelbrot family fractals"
+HOMEPAGE="http://fraqtive.mimec.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt5 cpu_flags_x86_sse2"
+
+RDEPEND="
+ !qt5? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ )
+ virtual/glu
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ epatch "${FILESDIR}/${P}-qt-includes.patch"
+
+ tc-export PKG_CONFIG
+ sed -i -e "s|-lGLU|$( ${PKG_CONFIG} --libs glu )|g" src/src.pro || die
+ local conf="release"
+
+ if use cpu_flags_x86_sse2; then
+ conf="$conf sse2"
+ else
+ conf="$conf no-sse2"
+ fi
+
+ echo "CONFIG += $conf" > "${S}"/config.pri
+ echo "PREFIX = ${EPREFIX}/usr" >> "${S}"/config.pri
+ # Don't strip wrt #252096
+ echo "QMAKE_STRIP =" >> "${S}"/config.pri
+
+ if use qt5; then
+ eqmake5
+ else
+ eqmake4
+ fi
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}