summaryrefslogtreecommitdiff
path: root/x11-misc/fluxter/fluxter-0.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/fluxter/fluxter-0.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/fluxter/fluxter-0.1.0.ebuild')
-rw-r--r--x11-misc/fluxter/fluxter-0.1.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/fluxter/fluxter-0.1.0.ebuild b/x11-misc/fluxter/fluxter-0.1.0.ebuild
new file mode 100644
index 000000000000..0bcbe35e507e
--- /dev/null
+++ b/x11-misc/fluxter/fluxter-0.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="workspace pager dockapp, particularly useful with the Fluxbox window manager"
+HOMEPAGE="http://www.isomedia.com/homes/stevencooper"
+SRC_URI="http://www.isomedia.com/homes/stevencooper/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+ x11-libs/libSM
+ x11-libs/libICE"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --datadir=/usr/share/commonbox
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog README TODO
+}