summaryrefslogtreecommitdiff
path: root/x11-misc/fluxter/fluxter-0.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-11 05:45:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-11 05:45:51 +0100
commit980af9d76d4b7d7541b41eeff427e5cbd5cf7ec3 (patch)
tree0b86d672e967b7f78ba20788fd85818efd54dc01 /x11-misc/fluxter/fluxter-0.1.0-r1.ebuild
parentf356af92b88d56b78588e81310493d4f5a2f6d18 (diff)
gentoo auto-resync : 11:05:2023 - 05:45:51
Diffstat (limited to 'x11-misc/fluxter/fluxter-0.1.0-r1.ebuild')
-rw-r--r--x11-misc/fluxter/fluxter-0.1.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/fluxter/fluxter-0.1.0-r1.ebuild b/x11-misc/fluxter/fluxter-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..a171049f9525
--- /dev/null
+++ b/x11-misc/fluxter/fluxter-0.1.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Workspace pager dockapp, particularly useful with the Fluxbox window manager"
+HOMEPAGE="http://www.isomedia.com/homes/stevencooper"
+SRC_URI="http://www.isomedia.com/homes/stevencooper/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc x86"
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libSM
+ x11-libs/libICE
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-asneeded.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++14
+
+ econf --datadir="${EPREFIX}"/usr/share/commonbox
+}