summaryrefslogtreecommitdiff
path: root/x11-misc/flow-pomodoro
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /x11-misc/flow-pomodoro
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'x11-misc/flow-pomodoro')
-rw-r--r--x11-misc/flow-pomodoro/Manifest3
-rw-r--r--x11-misc/flow-pomodoro/files/flow-pomodoro-1.2.0-respect-CXXFLAGS.patch23
-rw-r--r--x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild7
3 files changed, 30 insertions, 3 deletions
diff --git a/x11-misc/flow-pomodoro/Manifest b/x11-misc/flow-pomodoro/Manifest
index cd55fce20eb4..1dbac9d6f19c 100644
--- a/x11-misc/flow-pomodoro/Manifest
+++ b/x11-misc/flow-pomodoro/Manifest
@@ -1,4 +1,5 @@
AUX flow-pomodoro-1.2.0-qt-5.12.patch 1256 BLAKE2B b1316ed42f71418a2ce94421f8abb1f4ad560b6c39a686891e8ebc950c333e4bc9057a526fa7f408e2a75399e51daaa880cf22f266236b1def2b1d4a6a39b405 SHA512 ea42b0a7e66e3a1f6fd28f738fd0a1d78a41e506fa6e280e0f96162dd8890e669fa893c2e692f2ac259bcd9e6c9f8f6af68596895c48104ec733c2d7531c0b23
+AUX flow-pomodoro-1.2.0-respect-CXXFLAGS.patch 859 BLAKE2B 3144166259719b7a3675ae10d05d5ee9be371a58d69fb9cb82a812d3067be69df1924232159575fb169a6764c77db47a1526471cd5b68aecb509174fe904c5f5 SHA512 8bbc9700516cba663348df1dd625acb2b9bdc14ace43d5f69e0f17f7ba92f7764adf6edf003114e8c2a713b2ec654deb319c5b632c2d95fdba33629d98c7ca85
DIST flow-pomodoro-1.2.0.tar.gz 661888 BLAKE2B 776322a4c7bac37a7c5db7e3776838c8e7365745df87fcda557611055890d586b4fd1baa285d33bbf2bb1c77923c8d4751787dfe88c32dcd7d36827e8f9ff80f SHA512 1f347a679fe85e4751166c6aa8af3fda06c57844c0be7116266b2203d061abd1631cb994c0942f3fea9209064d9a49a230248ac101156132aa66a519438acccc
-EBUILD flow-pomodoro-1.2.0-r1.ebuild 603 BLAKE2B 26b11908bd3a3d2aa51b6a676cf4003806c3375c2ef2079330b3522f23d60ae94c8a1822b97ae60aab6c4a569b511499827497775760499454198b4097605542 SHA512 af9c0d26e9fb812601f85189f08829a621b95048f4eb2a51ea9231127868b8d31b5ec3809d8e25d49cf9c3a92660e8b9b3ea8b9d6f3544271ed4cfea286baf0e
+EBUILD flow-pomodoro-1.2.0-r1.ebuild 661 BLAKE2B 3bb5e86c92b2ae5ef05a9ac5179d01248f4336b21db8517a30c4e37f6e8a451224e6fdd63045b2747b6cdf6f20f501b7e566090a43f8ee208e101d977d121e5f SHA512 8adc240fca1ef3dbf9cec447ffe85469a42e9c2d29615d7500df8ea7ccb60fd85eb751d6479350a1432265c3484af0e8c5404197be333a5f7ff02b88fc788605
MISC metadata.xml 255 BLAKE2B 5c67c73b2cd0f3e2c0018103d3b5102c4cabdc35284f694385460e3b6ee7e2a1b9697b1e43e09ef601a14990fae3fd011314f5260a50398c9d878adf2adfab4f SHA512 e132f603e6f94db054583ec2884465f2bc459af138fb1263e49f454166ea4bb750c2c4591e0ed8c385382dbfc5f246316c3b2995aebe094131103cac53046b3b
diff --git a/x11-misc/flow-pomodoro/files/flow-pomodoro-1.2.0-respect-CXXFLAGS.patch b/x11-misc/flow-pomodoro/files/flow-pomodoro-1.2.0-respect-CXXFLAGS.patch
new file mode 100644
index 000000000000..0da271d43b06
--- /dev/null
+++ b/x11-misc/flow-pomodoro/files/flow-pomodoro-1.2.0-respect-CXXFLAGS.patch
@@ -0,0 +1,23 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -12,15 +12,16 @@ set(CMAKE_INCLUDE_CURRENT_DIR ON)
+ include_directories(${Qt5Core_INCLUDES})
+ include_directories(${Qt5Gui_INCLUDES})
+
+-set(CMAKE_CXX_FLAGS "${Qt5Gui_EXECUTABLE_COMPILE_FLAGS}")
++set(CMAKE_CXX_FLAGS "${Qt5Gui_EXECUTABLE_COMPILE_FLAGS} ${CMAKE_CXX_FLAGS}")
+
+ include(CheckCXXCompilerFlag)
++
+ CHECK_CXX_COMPILER_FLAG("-std=c++11" COMPILER_SUPPORTS_CXX11)
+ CHECK_CXX_COMPILER_FLAG("-std=c++0x" COMPILER_SUPPORTS_CXX0X)
++set(CMAKE_CXX_STANDARD_REQUIRED on)
++
+ if(COMPILER_SUPPORTS_CXX11)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+-elseif(COMPILER_SUPPORTS_CXX0X)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
++ set(CMAKE_CXX_STANDARD 11)
+ else()
+ message(STATUS "The compiler ${CMAKE_CXX_COMPILER} has no C++11 support. Please use a different C++ compiler.")
+ endif()
diff --git a/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild b/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild
index 114dc4f5294b..bd7d62f1034a 100644
--- a/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild
+++ b/x11-misc/flow-pomodoro/flow-pomodoro-1.2.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,4 +25,7 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${P}-qt-5.12.patch" )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.0-qt-5.12.patch
+ "${FILESDIR}"/${PN}-1.2.0-respect-CXXFLAGS.patch
+)