summaryrefslogtreecommitdiff
path: root/x11-misc/fbpanel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-21 12:05:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-21 12:05:28 +0100
commit490ef2c2dc8b4e808f37add1adee21a754efd9a9 (patch)
treee235cdf15550b3d2f644b6fc4a8aa726971416f5 /x11-misc/fbpanel
parentda7ae1dd1fccb6b3c0e4763ab983ad96d57bf463 (diff)
gentoo auto-resync : 21:04:2024 - 12:05:28
Diffstat (limited to 'x11-misc/fbpanel')
-rw-r--r--x11-misc/fbpanel/Manifest1
-rw-r--r--x11-misc/fbpanel/fbpanel-7.0-r4.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/x11-misc/fbpanel/Manifest b/x11-misc/fbpanel/Manifest
index fe4a3d28ce9f..14f431e3e6f5 100644
--- a/x11-misc/fbpanel/Manifest
+++ b/x11-misc/fbpanel/Manifest
@@ -7,4 +7,5 @@ AUX fbpanel-7.0-python3.10.patch 410 BLAKE2B cd4c57ea9677062a127e698d248b9ec15b3
AUX fbpanel-7.0-remove-gdk-pixbuf-xlib.h.patch 801 BLAKE2B 49a0d7217b5e44c902200d9fc4cee57d245386cbf400e21a24672b2c121578d09dd440d56f05483afbe3e6083bbe65fdafb162e35624d7bd0f7f34b1639d2737 SHA512 d4fc104faf4bc4c9ead54530c3e00e82d9ab3c356d635c824d206dd2fa64c64b8ff57594cb6fbbef9725df30f10994de3a213aff8f1eb7fc8b59cd08498e3148
DIST fbpanel-7.0.tar.gz 3746477 BLAKE2B 6bc8ef39d44768b5fc9fc4c58ea0b89c723f0e5239198d3b1a5f6fe27252bf22c87fec5beb13fa3371af6c218e592d67d04644bd82cc62f357def610680fc2d2 SHA512 9706a96569c41241de4dbd250c9d6a473b53a5e26e880f4c782041b2b91c7570046e1bee3070059fd2d333fb7159490732ef397b86701c72d4c65c0784948874
EBUILD fbpanel-7.0-r3.ebuild 1594 BLAKE2B ca3022d9414c4013249bbd131890ac677eaea8bbab3f525b3ea3efba77c2da0613134a9449013aad6c63bb9c63bdf7e36262525d79a4596fca633db6da725b19 SHA512 33fa67f1c2ff4927cc4abe7b340ed4d4c8cc50b3a82a244a52ab0757e46ea0b1caa4b5a5f332b2b591dc7ae1ba3140af44dda65e44e7cebe7bc33df543a6d58a
+EBUILD fbpanel-7.0-r4.ebuild 1627 BLAKE2B 3e7536522967c38d11ccea251d8b06a1a3d8941379a262098659acff76830ef9ed171f0ef0868519af89af4a1b64fee2425b28d1551f82fc827b73764e3df846 SHA512 a0d56795e9681f537566eb967227cc8c6d8ab9bfebd4a928f9a0522143b432199c75122f6b1fd70aace6406a21017b8ea021d6956315e2cdd7b86017159641c3
MISC metadata.xml 252 BLAKE2B cc4fe64f3e9531d55a19098705558d2e02a395279ba605d6c598ef6b9a13cb0a17cc9cdae4f9e2ea30f34abb58f0591b3c4f11a6e42b385ee7c0855251b37f20 SHA512 22086ac1bc91a06382f92625473824dd26f60fd00cf691ad3b587f45b75aadb9f0c66bb4af93ab02fe059b00f504770c642342d81dee9f01b950b99c1f85ea9d
diff --git a/x11-misc/fbpanel/fbpanel-7.0-r4.ebuild b/x11-misc/fbpanel/fbpanel-7.0-r4.ebuild
new file mode 100644
index 000000000000..04f05780e684
--- /dev/null
+++ b/x11-misc/fbpanel/fbpanel-7.0-r4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit edo python-any-r1 toolchain-funcs
+
+DESCRIPTION="Light-weight X11 desktop panel"
+HOMEPAGE="https://aanatoly.github.io/fbpanel/"
+SRC_URI="https://github.com/aanatoly/fbpanel/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT LGPL-2+ GPL-2+" # bug #795591
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="alsa"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ alsa? ( media-libs/alsa-lib )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.1-underlinking.patch
+ "${FILESDIR}"/${PN}-7.0-clang.patch
+ "${FILESDIR}"/${PN}-7.0-fno-common.patch
+ "${FILESDIR}"/${PN}-7.0-images.patch
+ "${FILESDIR}"/${PN}-7.0-python3-shebangs.patch
+ "${FILESDIR}"/${PN}-7.0-remove-gdk-pixbuf-xlib.h.patch
+ "${FILESDIR}"/${PN}-7.0-python3.10.patch
+)
+
+src_prepare() {
+ default
+ 2to3 -n -w --no-diffs configure .config/*.py || die
+}
+
+src_configure() {
+ tc-export CC
+
+ # not autotools based
+ local confargs=(
+ V=1
+ --mandir="${EPREFIX}"/usr/share/man/man1
+ --datadir="${EPREFIX}"/usr/share/${PN}
+ --prefix="${EPREFIX}"/usr
+ --libdir="${EPREFIX}"/usr/$(get_libdir)/${PN}
+ $(usex alsa --sound --no-sound)
+ )
+
+ edo ./configure "${confargs[@]}"
+}
+
+pkg_postinst() {
+ elog "For the volume plugin to work, you need to configure your kernel"
+ elog "with CONFIG_SND_MIXER_OSS or CONFIG_SOUND_PRIME or some other means"
+ elog "that provide the /dev/mixer device node."
+}