summaryrefslogtreecommitdiff
path: root/x11-misc/evolvotron
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /x11-misc/evolvotron
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'x11-misc/evolvotron')
-rw-r--r--x11-misc/evolvotron/Manifest3
-rw-r--r--x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild26
-rw-r--r--x11-misc/evolvotron/files/evolvotron-0.7.1-gcc11-predicate-decl.patch21
3 files changed, 36 insertions, 14 deletions
diff --git a/x11-misc/evolvotron/Manifest b/x11-misc/evolvotron/Manifest
index 10a93b7089ce..c520fab5b8b9 100644
--- a/x11-misc/evolvotron/Manifest
+++ b/x11-misc/evolvotron/Manifest
@@ -1,3 +1,4 @@
+AUX evolvotron-0.7.1-gcc11-predicate-decl.patch 1065 BLAKE2B 2d5b22c2f239f211a321d0610ac573a0dbce528ff249d39d954bbb51e4b4a7cd58134e5833ddd73b8683db6c064928550c98f6600fa199e77b77c7f67515f595 SHA512 bee1abc69d8664ee977a45e0ab5f36466048bb6fbab1c96b98d7b28163070bc6f3bb9bd0ba2963f224f881836ddf2c8b3cce98771a664a6345485f849814a03c
DIST evolvotron-0.7.1.tar.gz 179516 BLAKE2B b73c813fdf134e0e4c7882e06a12bc06acfb6dcdf4a38043c4c30027bf00da10df85d6877abdbd8ca6393496038ba9fa0c32a16b0f37dd14d72cc63c00a17d1c SHA512 74f48dc0881a82d999ccc910df026da80fcc46a906fe2fbb8edbae50a1fa42a3379087f00dd21fd9e5d69cee7c6fc745b80f8703b1af1ebc3a1cdb52ffbe16e9
-EBUILD evolvotron-0.7.1-r1.ebuild 878 BLAKE2B 534a03152a5e38b5aa90c7db36c5b29d4ee65853656d87f0311b2a7afe2b7114ca0caba518d2f8da6b05ff2e60155930382b13d360b35255918905820eb88c6a SHA512 72d8245cdd4f378ab0a4412996dc2dd2384d6f18ba63b872f2530e83c63eabced18e3d989652a493054e36c033576948d15825a66d4977e875a1a55bd16843df
+EBUILD evolvotron-0.7.1-r1.ebuild 973 BLAKE2B ce6f5abd16fc5a35f0caa833b00128eb9d7780f3b00a6e7ca13139a44cfbd00f6e451ca1c3045196c1cb38a37b907bfdc713665bad39dcf83a6d211c797e7c2f SHA512 a7570e3a31295d74931d795c02a2e560fae2adb1160a256242b4ab5a827ee31dc4f6afe7db7967321b2042bf150dac482a9e189daa2037f139872f4098c57be3
MISC metadata.xml 356 BLAKE2B bcffe50af78659801374955b8bb13970760d0d565c89a210d2ee98059078df0bbd5634e95f2cbc9e922e8b29f21cacb7b6339b6004ac4619b21706b7da85be14 SHA512 7cea09fe7cfe3d43572ab13f83921cd252cb4a12bfc9fb4e2629cbd96c90a07fef8613090514ad562ee112960f88bdcbbe18daa185470780bd714e95aa6bfb47
diff --git a/x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild b/x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild
index 2cfacb68a556..52497e1e2485 100644
--- a/x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild
+++ b/x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit qmake-utils
DESCRIPTION="Generative art image evolver"
-HOMEPAGE="
- https://sourceforge.net/projects/evolvotron/
-"
+HOMEPAGE="https://sourceforge.net/projects/evolvotron/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+S="${WORKDIR}"/${PN}
LICENSE="GPL-2"
SLOT="0"
@@ -23,13 +23,12 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
-DOCS=(
- BUGS NEWS README TODO USAGE
-)
-HTML_DOCS=(
- evolvotron.html
+DOCS=( BUGS NEWS README TODO USAGE )
+HTML_DOCS=( evolvotron.html )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.1-gcc11-predicate-decl.patch
)
-S=${WORKDIR}/${PN}
src_configure() {
eqmake5 main.pro
@@ -37,9 +36,9 @@ src_configure() {
src_compile() {
local etsubdir
- for etsubdir in \
- libfunction libevolvotron evolvotron evolvotron_render evolvotron_mutate
- do
+ local targets=( libfunction libevolvotron evolvotron evolvotron_render evolvotron_mutate )
+
+ for etsubdir in ${targets[@]}; do
emake sub-${etsubdir}
done
}
@@ -49,6 +48,7 @@ src_install() {
for bin in ${PN}{,_mutate,_render}; do
dobin ${bin}/${bin}
done
+
doman man/man1/*
einstalldocs
}
diff --git a/x11-misc/evolvotron/files/evolvotron-0.7.1-gcc11-predicate-decl.patch b/x11-misc/evolvotron/files/evolvotron-0.7.1-gcc11-predicate-decl.patch
new file mode 100644
index 000000000000..e21de137f746
--- /dev/null
+++ b/x11-misc/evolvotron/files/evolvotron-0.7.1-gcc11-predicate-decl.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/787101
+--- a/libevolvotron/mutatable_image_computer_farm.h
++++ b/libevolvotron/mutatable_image_computer_farm.h
+@@ -45,7 +45,7 @@ class MutatableImageComputerFarm
+ {
+ public:
+ //! Compare task priorities.
+- bool operator()(const boost::shared_ptr<const MutatableImageComputerTask>& t0,const boost::shared_ptr<const MutatableImageComputerTask>& t1)
++ bool operator()(const boost::shared_ptr<const MutatableImageComputerTask>& t0,const boost::shared_ptr<const MutatableImageComputerTask>& t1) const
+ {
+ return (t0->priority() < t1->priority());
+ }
+@@ -56,7 +56,7 @@ class MutatableImageComputerFarm
+ {
+ public:
+ //! Compare task priorities.
+- bool operator()(const boost::shared_ptr<const MutatableImageComputerTask>& t0,const boost::shared_ptr<const MutatableImageComputerTask>& t1)
++ bool operator()(const boost::shared_ptr<const MutatableImageComputerTask>& t0,const boost::shared_ptr<const MutatableImageComputerTask>& t1) const
+ {
+ return (t0->priority() > t1->priority());
+ }