summaryrefslogtreecommitdiff
path: root/x11-misc/enlightenment-extra/enlightenment-extra-0.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /x11-misc/enlightenment-extra/enlightenment-extra-0.0.1.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'x11-misc/enlightenment-extra/enlightenment-extra-0.0.1.ebuild')
-rw-r--r--x11-misc/enlightenment-extra/enlightenment-extra-0.0.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/enlightenment-extra/enlightenment-extra-0.0.1.ebuild b/x11-misc/enlightenment-extra/enlightenment-extra-0.0.1.ebuild
new file mode 100644
index 000000000000..a7d39571c7dd
--- /dev/null
+++ b/x11-misc/enlightenment-extra/enlightenment-extra-0.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/enlightenment-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="An app for downloading themes and add-ons to Enlightenment WM"
+HOMEPAGE="https://extra.enlightenment.org"
+SRC_URI="https://download.enlightenment.org/rel/apps/${MY_PN}/${MY_P}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/efl-1.18[X]"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+S="${WORKDIR}"/"${MY_P}"
+
+src_prepare() {
+ default
+
+ # Fix a QA issue, https://phab.enlightenment.org/T7167
+ sed -i '/Version=/d' data/desktop/extra.desktop* || die
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable nls)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}