summaryrefslogtreecommitdiff
path: root/x11-misc/dunst/dunst-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
commit6d691ad5b6239929063441bbd14c489e92e7396e (patch)
treee294f87b1ce66397fee1273bd6c7131aeb586f51 /x11-misc/dunst/dunst-9999.ebuild
parentd99093fb4bb5652015c06274d64083daa2439e4f (diff)
gentoo resync : 05.03.2021
Diffstat (limited to 'x11-misc/dunst/dunst-9999.ebuild')
-rw-r--r--x11-misc/dunst/dunst-9999.ebuild42
1 files changed, 26 insertions, 16 deletions
diff --git a/x11-misc/dunst/dunst-9999.ebuild b/x11-misc/dunst/dunst-9999.ebuild
index f341b6af6627..db38e7cda0ae 100644
--- a/x11-misc/dunst/dunst-9999.ebuild
+++ b/x11-misc/dunst/dunst-9999.ebuild
@@ -1,16 +1,24 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 toolchain-funcs
+inherit systemd toolchain-funcs
DESCRIPTION="Customizable and lightweight notification-daemon"
-HOMEPAGE="https://dunst-project.org/ https://github.com/dunst-project/dunst"
-EGIT_REPO_URI="https://github.com/${PN}-project/${PN}"
+HOMEPAGE="https://dunst-project.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dunst-project/dunst"
+else
+ SRC_URI="https://github.com/dunst-project/dunst/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
+IUSE="test wayland"
+RESTRICT="!test? ( test )"
DEPEND="
dev-libs/glib:2
@@ -23,28 +31,30 @@ DEPEND="
x11-libs/libXrandr
x11-libs/libnotify
x11-libs/pango[X]
+ wayland? ( dev-libs/wayland )
"
+RDEPEND="${DEPEND}"
BDEPEND="
dev-lang/perl
virtual/pkgconfig
-"
-RDEPEND="
- ${DEPEND}
+ wayland? ( dev-libs/wayland-protocols )
"
-src_prepare() {
- sed -i -e "/^CFLAGS/ { s:-g::;s:-O.:: }" config.mk || die
-
- default
-}
+PATCHES=( "${FILESDIR}"/${PN}-1.6.1-no-Os.patch )
src_configure() {
tc-export CC PKG_CONFIG
default
}
-src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" install
+src_compile() {
+ emake WAYLAND=$(usex wayland 1 0) SYSTEMD=0
+ sed -e "s|##PREFIX##|${EPREFIX}/usr|" \
+ -i dunst.systemd.service.in > dunst.service
+}
- dodoc AUTHORS CHANGELOG.md README.md RELEASE_NOTES
+src_install() {
+ emake WAYLAND=$(usex wayland 1 0) SYSTEMD=0 \
+ DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ systemd_dounit dunst.service
}