summaryrefslogtreecommitdiff
path: root/x11-misc/dunst/dunst-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/dunst/dunst-1.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/dunst/dunst-1.1.0.ebuild')
-rw-r--r--x11-misc/dunst/dunst-1.1.0.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/x11-misc/dunst/dunst-1.1.0.ebuild b/x11-misc/dunst/dunst-1.1.0.ebuild
new file mode 100644
index 000000000000..1ce9d2c4edbd
--- /dev/null
+++ b/x11-misc/dunst/dunst-1.1.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="customizable and lightweight notification-daemon"
+HOMEPAGE="http://www.knopwob.org/dunst/"
+SRC_URI="http://www.knopwob.org/public/dunst-release/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="dunstify"
+
+CDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxdg-basedir
+ sys-apps/dbus
+ x11-libs/cairo[X,glib]
+ x11-libs/gdk-pixbuf
+ x11-libs/libXScrnSaver
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/pango[X]
+ dunstify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${CDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS/ { s:-g::; s:-O.:: }' \
+ -e '/^CPPFLAGS/ s:-D_BSD_SOURCE:-D_DEFAULT_SOURCE:' \
+ config.mk || die
+
+ sed -i \
+ -e 's:registration_id > 0:(&):' \
+ dbus.c || die
+
+ sed -i \
+ -e '/g_print.*iter->data/ s:iter->data:(char *)&:' \
+ dunstify.c || die
+
+ default
+}
+
+src_compile() {
+ tc-export CC
+ emake V=
+
+ use dunstify && emake V= dunstify
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+
+ if use dunstify; then
+ dobin dunstify
+ fi
+
+ dodoc CHANGELOG
+}