summaryrefslogtreecommitdiff
path: root/x11-misc/dsx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /x11-misc/dsx
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'x11-misc/dsx')
-rw-r--r--x11-misc/dsx/Manifest3
-rw-r--r--x11-misc/dsx/dsx-0.1-r1.ebuild29
-rw-r--r--x11-misc/dsx/files/dsx-0.172
-rw-r--r--x11-misc/dsx/metadata.xml8
4 files changed, 0 insertions, 112 deletions
diff --git a/x11-misc/dsx/Manifest b/x11-misc/dsx/Manifest
deleted file mode 100644
index 3e67e5a410fb..000000000000
--- a/x11-misc/dsx/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-AUX dsx-0.1 2218 BLAKE2B dc20fbd18c0fe455a704cd0384e9d310e5f3b378842a196de5d0969b844117a1444fbe0bb04c2f2a6e698216a0eff838a95052333601befcbbf755bb825cedc6 SHA512 918d05297dc39166fe1684b306441c519bdf41e56a94d4a5f090698f69fdebb1f4d077d07be4e6d5a22614f163eb4ff8645c8751397ba52e265daece840178a9
-EBUILD dsx-0.1-r1.ebuild 530 BLAKE2B a1d3d2e332cb106552287ff6629a209f1b39e1647cb66b5b6bd01783f11cc536b40bd654b7a24a2ff6e2093fd524d38e9cd24d36b60b8d014b552548dcbc51b9 SHA512 f8a6a0d2cb016052524823385c6d6238fe648525ec8efb71a952942b1716676effab5f0a09c2a4409c25c1da7d374d6b86af996043f653303cf05bc2be3b06e5
-MISC metadata.xml 272 BLAKE2B 4dbd2b5ae92564a97b2a06ab0ec6562e8dce2dd636aaf0788ee09f8688ca5d5b6483084a65366dfbe6d144d30170e5558bc5759adecb96abb405ea96a5147285 SHA512 ebe67da08587903b5b82fc194aa3c8f1ab65371f60d2c134928362e089550d9e9fd9531bffe8b676a345b5bf0ab209ce7f50d37d98201a88176f002e17582493
diff --git a/x11-misc/dsx/dsx-0.1-r1.ebuild b/x11-misc/dsx/dsx-0.1-r1.ebuild
deleted file mode 100644
index 6b49cac790e8..000000000000
--- a/x11-misc/dsx/dsx-0.1-r1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1
-
-DESCRIPTION="Command line selection of your X desktop environment"
-HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND=""
-RDEPEND="
- ${PYTHON_DEPS}
- x11-apps/xinit"
-
-S="${WORKDIR}"
-
-src_install() {
- python_newscript "${FILESDIR}/${P}" "${PN}"
-}
diff --git a/x11-misc/dsx/files/dsx-0.1 b/x11-misc/dsx/files/dsx-0.1
deleted file mode 100644
index d8f5e7192928..000000000000
--- a/x11-misc/dsx/files/dsx-0.1
+++ /dev/null
@@ -1,72 +0,0 @@
-#!/usr/bin/env python
-# dsx is Mandrakesoft's Xtart modified to work with a Gentoo Linux system.
-# Gentoo doesn't use a wmsession.d directory, so we're going to accept the
-# /etc/X11/Sessions executables as our menu and our command parameters.
-# I also tried to increase the robustness of the entry checking and make the
-# error messages less condescending.
-# The 0 option for "no wm" was removed. I altered it to run option 1 instead.
-
-### Original copyright / license message from Xtart... ###
-# This is an official linux-mandrake extension of the X windowing system for
-# the benefit of Declan Moriarty Copyright 2001 by civileme@mandrakesoft all
-# rights reserved. Use is hereby granted under the GNU General Publoic
-# License version 2 or any future version of said license at the user's option
-#
-# No Warranty of course.
-# This program is designed for those who want to work in concole and
-# occasionally boot into window managers or who want to avoid theme
-# persistence from one WM to another.
-################
-import sys
-import os
-import popen2
-import string
-import math
-def complain():
- print 'X initiation aborted on invalid selection.'
- sys.exit(0)
- return
-print
-print 'Welcome to the Desktop Selector for X'
-print
-fspc=os.path.expanduser('~')+'/'
-io=popen2.Popen3('ls /etc/X11/Sessions',1)
-L=io.fromchild.readlines()
-Sessions={}
-Sessionkeys=[]
-primekey=0
-for k in L:
- primekey+=1
- name=k[:-1]
- command='/etc/X11/Sessions/'+k[:-1]
- Sessions[primekey]=(name, command)
-Sessionkeys=Sessions.keys()
-Sessionkeys.sort()
-for j in Sessionkeys:
- if os.system('[ -x '+Sessions[j][1]+' ]') == 0:
- print j, Sessions[j][0]
- pass
-print
-sys.stdin.flush()
-s=raw_input('Enter the number of your desired desktop environment [1]: ')
-if len(s)==0:
- s='1'
-if s=='0':
- s='1'
-for j in range(len(s)):
- if string.find(string.digits,s[j]) == -1:
- print "'" + s[j] + "' isn't a digit."
- complain()
-if len(s)>int(math.log10(primekey))+1:
- print "That number is too big."
- complain()
-well=int(s)
-wellformed=Sessions.has_key(well)
-if wellformed:
- os.execvp('xinit',Sessions[well])
-else:
- print
- print 'Your selection was invalid.'
- print
- complain()
-
diff --git a/x11-misc/dsx/metadata.xml b/x11-misc/dsx/metadata.xml
deleted file mode 100644
index 49c86a887b6a..000000000000
--- a/x11-misc/dsx/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>desktop-misc@gentoo.org</email>
- <name>Gentoo Desktop Miscellaneous Project</name>
-</maintainer>
-</pkgmetadata>