summaryrefslogtreecommitdiff
path: root/x11-misc/clipmenu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /x11-misc/clipmenu
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'x11-misc/clipmenu')
-rw-r--r--x11-misc/clipmenu/Manifest7
-rw-r--r--x11-misc/clipmenu/clipmenu-6.0.1.ebuild30
-rw-r--r--x11-misc/clipmenu/clipmenu-6.1.0.ebuild34
-rw-r--r--x11-misc/clipmenu/clipmenu-6.2.0.ebuild34
-rw-r--r--x11-misc/clipmenu/metadata.xml12
5 files changed, 117 insertions, 0 deletions
diff --git a/x11-misc/clipmenu/Manifest b/x11-misc/clipmenu/Manifest
new file mode 100644
index 000000000000..8748373c83f3
--- /dev/null
+++ b/x11-misc/clipmenu/Manifest
@@ -0,0 +1,7 @@
+DIST clipmenu-6.0.1.tar.gz 7219 BLAKE2B 85d61c34e3b964e0a39051a1443b1498fedab1f5b45c61f3a8b6c0a63058642ff4fcfabc7d4913893320b5196edac2c5a9ad5a84b71a9d2191a3e147283a816c SHA512 0c91ad3a873081a6f9abfcc7a4a9be7cbd4ca5017f447dac204042ae3f051c550111c73d9d06f1d2a7a6783cfda631154373a932ea40315e72907d52120d4801
+DIST clipmenu-6.1.0.tar.gz 8711 BLAKE2B a37f0f52343a4f22fdf4a37a57a2c715edd47aa1b77c90cf95f9af11a8107967eb24410ed43cee52ec5db5a1276c5e9bdf082668795f3054840b4f30e511ac55 SHA512 1392b08025b564dc17ca44e43847fdea85886b89fdd5426635c9c16d204610c6a9cc19297a20cdbc2eeef2c878adbfe994a2cfd05176457ca6fcbc75bc036acc
+DIST clipmenu-6.2.0.tar.gz 9019 BLAKE2B 2dddd900483656a38b2335f994a46302af797b0f47509b0bd2c1a302e1c27729cd80091a4c8bfd587844f7ee8c271742aea668910553d9a4c54595d18e4f1ec7 SHA512 adfd649a120264552e2c05314ae2ad039055308f77d620dbb3fc206e4244a6f1f2e5ed4a7e86fd547a78692aebaec1761528e10408d838f80def99959ef58295
+EBUILD clipmenu-6.0.1.ebuild 581 BLAKE2B 1dc46e286767a05c5c0defe74bab3d4fd403915df398b724da0d603eaca49731f52a17b203b3377c283d5e231713d308c274c330794258cf3c15252983857dc9 SHA512 a9a25ec760f995d863f06c21133bed83ec95e31e4547d34ff0eb67af7e851950c5f232a1c30ba4bcc4e629319898afdc65eb51a8a51fa5169d2299a0b0603ca9
+EBUILD clipmenu-6.1.0.ebuild 603 BLAKE2B fedce7c991689e9e6a9e0d4f1bd604241d309bd921499752705d1b116a90d2052de491ddb6bf44f343d92d56a3086f5ef086c710f5edd17046ff8657baa06649 SHA512 5b6fb72b91e1e439e9ed821bf795234a6362b2a5aca6f528e74e6c2f2a99a8bc37f8c7c946e3ad5337165a7d0f97922318a727ac7860e1ef5c64791ffc5d7f48
+EBUILD clipmenu-6.2.0.ebuild 611 BLAKE2B 28d0919bae816876108f33f51154006fff3af824057952a82ea0850ee746b7dbd2a1aea8f397892c01a68e1cb2d16b4809d90feee77255c03df4882a8760fcd1 SHA512 60f16a070fcc28243e072a0c85ccac06d4c207478c77ac802f5d772e3070daff26ac4e2148b5563de4395d0d887af29a3288d37d56a5d1130c3f73e4df64a7ad
+MISC metadata.xml 364 BLAKE2B 4f0c3d96c42f1ae903968e3cb3b0a28b5d0a3881c74eab0347abf13262547aa218a83bd907ec9a5c0d906948f5cb57c97372f07630368637326277fcb75c4db5 SHA512 478344a69216a5d9aa8b69a0252c171c23ae8719529fbecf912d8f298cb28bb85fd9506af2a5a4b77ddd3048c60d479dee0e5ba7909d661886d35c20107527fe
diff --git a/x11-misc/clipmenu/clipmenu-6.0.1.ebuild b/x11-misc/clipmenu/clipmenu-6.0.1.ebuild
new file mode 100644
index 000000000000..08751d666899
--- /dev/null
+++ b/x11-misc/clipmenu/clipmenu-6.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="Clipboard management using dmenu"
+HOMEPAGE="https://github.com/cdown/clipmenu"
+SRC_URI="https://github.com/cdown/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-misc/clipnotify
+ x11-misc/dmenu
+ x11-misc/xsel
+"
+
+src_install() {
+ local binfile
+ for binfile in clipdel clipfsck clipmenu clipmenud; do
+ dobin ${binfile}
+ done
+
+ systemd_douserunit "init/clipmenud.service"
+}
diff --git a/x11-misc/clipmenu/clipmenu-6.1.0.ebuild b/x11-misc/clipmenu/clipmenu-6.1.0.ebuild
new file mode 100644
index 000000000000..47494c5e02a0
--- /dev/null
+++ b/x11-misc/clipmenu/clipmenu-6.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="Clipboard management using dmenu"
+HOMEPAGE="https://github.com/cdown/clipmenu"
+SRC_URI="https://github.com/cdown/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-misc/clipnotify
+ x11-misc/dmenu
+ x11-misc/xsel
+"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local binfile
+ for binfile in clipdel clipfsck clipmenu clipmenud; do
+ dobin ${binfile}
+ done
+
+ systemd_douserunit "init/clipmenud.service"
+}
diff --git a/x11-misc/clipmenu/clipmenu-6.2.0.ebuild b/x11-misc/clipmenu/clipmenu-6.2.0.ebuild
new file mode 100644
index 000000000000..cc2eeecc5417
--- /dev/null
+++ b/x11-misc/clipmenu/clipmenu-6.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="Clipboard management using dmenu"
+HOMEPAGE="https://github.com/cdown/clipmenu"
+SRC_URI="https://github.com/cdown/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-misc/clipnotify
+ x11-misc/dmenu
+ x11-misc/xsel
+"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local binfile
+ for binfile in clipctl clipdel clipfsck clipmenu clipmenud; do
+ dobin ${binfile}
+ done
+
+ systemd_douserunit "init/clipmenud.service"
+}
diff --git a/x11-misc/clipmenu/metadata.xml b/x11-misc/clipmenu/metadata.xml
new file mode 100644
index 000000000000..b99ff18165e9
--- /dev/null
+++ b/x11-misc/clipmenu/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>erkiferenc@gmail.com</email>
+ <name>Ferenc Erki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>