summaryrefslogtreecommitdiff
path: root/x11-misc/cairo-clock/cairo-clock-0.3.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /x11-misc/cairo-clock/cairo-clock-0.3.4-r2.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'x11-misc/cairo-clock/cairo-clock-0.3.4-r2.ebuild')
-rw-r--r--x11-misc/cairo-clock/cairo-clock-0.3.4-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/cairo-clock/cairo-clock-0.3.4-r2.ebuild b/x11-misc/cairo-clock/cairo-clock-0.3.4-r2.ebuild
new file mode 100644
index 000000000000..675a9bf64b02
--- /dev/null
+++ b/x11-misc/cairo-clock/cairo-clock-0.3.4-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="An analog clock displaying the system-time"
+HOMEPAGE="https://launchpad.net/cairo-clock"
+SRC_URI="http://macslow.thepimp.net/projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.8
+ >=gnome-base/libglade-2.6
+ >=gnome-base/librsvg-2.14
+ >=x11-libs/cairo-1.2
+ >=x11-libs/gtk+-2.10:2
+ >=x11-libs/pango-1.10
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-desktop.patch
+ "${FILESDIR}"/${P}-linker.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ gzip -d "${ED}"/usr/share/man/man1/cairo-clock.1.gz || die
+}