summaryrefslogtreecommitdiff
path: root/x11-misc/birdtray
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-19 00:30:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-19 00:30:04 +0000
commit781c9128468d2e8302221d4d7152ae09cffc4a9e (patch)
tree1f0892c391dbb3e56d61a206fdc800034917eead /x11-misc/birdtray
parentcade0827f4ab3a7b13c870b7841c4462dde54dc6 (diff)
gentoo auto-resync : 19:03:2025 - 00:30:03
Diffstat (limited to 'x11-misc/birdtray')
-rw-r--r--x11-misc/birdtray/Manifest2
-rw-r--r--x11-misc/birdtray/birdtray-1.11.4_p20250318.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/birdtray/Manifest b/x11-misc/birdtray/Manifest
index 187a1dfd5e07..f237a8bf5aa6 100644
--- a/x11-misc/birdtray/Manifest
+++ b/x11-misc/birdtray/Manifest
@@ -1,4 +1,6 @@
DIST birdtray-1.11.4.gh.tar.gz 867399 BLAKE2B e3e5663bb343d991c66ff0bd774fdc1abf74a5e94f7ea42ecfe5e16f3c1be932fe8d91ae0d9a6e43d75475671f4f18df0a90f80a09e58892d9629c4cc464b729 SHA512 a3eeeb93fea3f32bbf6a43944d76d0c3990a26db0abbad52102aa72f15f9a32a746620ca347444dab0d90393785aeada7ffb9ec901f91b4701fb128c4e7e628c
+DIST birdtray-1.11.4_p20250318.tar.xz 1373564 BLAKE2B 75798b1dbbaa91a049a6d66c6f97e381046c0d93707a2263fd24f83803e51ad20cb9d95ca8ee3f11241a55df853860b577996a877fd178758861e710f592e112 SHA512 573263e616a3fc0bc1600a7a200793b0ff3dbaeef15d7b121205788abf51e0e5b14f83ef8101e7f6df09df48b4870057bcf5f16edc9d9d8d7be5f8ef96b7058d
EBUILD birdtray-1.11.4.ebuild 960 BLAKE2B c367b4a5c59080a59a0543b76a148582255950b7814b8b2fe6d8afea12ee6992cce48f5ddd5b0add4ec4d71576caf3cbce9dcb2b7d59fd2a38a2286b4da2544c SHA512 afa67efd378d3f044513f93c47612f351aeee8845167b4466bed305fd5e248588b06cb99225f5f393b588681dff81a03de18a6d65b5a3f354b07d330ecbec32c
+EBUILD birdtray-1.11.4_p20250318.ebuild 1083 BLAKE2B 0b9e9a61090699fbbb19fea97bbc13fa26238ff935fddd1a026f70ff3e8a4b21dc43b8b7b3266734d06d8d7258aa1a45a391f28765e7e2cb4785322c3a996674 SHA512 22e5ae817a8e266b6eec2a44adddeaae8666572749644f4e7495016cbb027b83c94121cd04ce11e6a7b73c1bd433af259339604cfd8e6838d4bb54e8c15efcb2
EBUILD birdtray-9999.ebuild 1075 BLAKE2B 569bc3ed5a2ebc0ee1116fd10ebaf87c28e57d673a370a2031379de144d107a28e983f1fbe8db0549c313fc6d741a6fbb1c327abbb8300fcafd0d643c9973555 SHA512 db6361ea3106ea39c8d4472a3f23cdff06d079aa3528c47ece6813fc56a4e59b7fab60ca3e6a510b59a1a15dff667758057cad0981a1b326011801f2a2a8b219
MISC metadata.xml 338 BLAKE2B 75ecb2600046ef12230de247cd9b4964fb987d43a45f1b4e2a38d0869599d1a4f27c398b5164134b0341edddf731e692981aae75339daea4c30a6e4bafcad4f3 SHA512 3082be6254c7a8e3647a1a908898b2649d2b007549c77699fb033dd987a1b1b58771f2d5ba0217b78b96058603e6ff6a6f8d9ec5470b109e6c4abf5c3afdea5d
diff --git a/x11-misc/birdtray/birdtray-1.11.4_p20250318.ebuild b/x11-misc/birdtray/birdtray-1.11.4_p20250318.ebuild
new file mode 100644
index 000000000000..552b553fc074
--- /dev/null
+++ b/x11-misc/birdtray/birdtray-1.11.4_p20250318.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="A new mail system tray notification icon for Thunderbird"
+HOMEPAGE="https://github.com/gyunaev/birdtray"
+
+# bug 951139 - Add a snapshot to use qt6
+# Just appended '20250318' into src/version.h to display that is a snapshot version
+SRC_URI="https://dev.gentoo.org/~ago/distfiles/birdtray-1.11.4_p20250318.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="dev-db/sqlite:=
+ dev-qt/qtbase:6
+ dev-qt/qtsvg:6
+ x11-libs/libX11"
+
+DEPEND="${RDEPEND}"
+
+# https://github.com/gyunaev/birdtray/commit/74a97df3a17efd5ef679b8eed6999b97abc23f10
+# translations have been made optional, let's see how we would manage them
+BDEPEND="dev-qt/qttools:6"
+
+src_prepare() {
+ # https://github.com/gyunaev/birdtray/issues/606
+ sed -i 's/Qt5LinguistTools/Qt6LinguistTools/g' CMakeLists.txt || die
+ sed -i 's/qt5_/qt6_/g' CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}