summaryrefslogtreecommitdiff
path: root/x11-misc/bbtime/bbtime-0.1.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/bbtime/bbtime-0.1.5-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/bbtime/bbtime-0.1.5-r1.ebuild')
-rw-r--r--x11-misc/bbtime/bbtime-0.1.5-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/bbtime/bbtime-0.1.5-r1.ebuild b/x11-misc/bbtime/bbtime-0.1.5-r1.ebuild
new file mode 100644
index 000000000000..0b4a858cf867
--- /dev/null
+++ b/x11-misc/bbtime/bbtime-0.1.5-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="blackbox time watcher"
+HOMEPAGE="https://sourceforge.net/projects/bbtools/"
+SRC_URI="mirror://sourceforge/bbtools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+DOCS=( README AUTHORS BUGS ChangeLog NEWS TODO data/README.bbtime )
+PATCHES=( "${FILESDIR}"/${P}-asneeded.patch )
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install () {
+ default
+ rm "${ED%/}"/usr/share/bbtools/README.bbtime || die
+ # since multiple bbtools packages provide this file, install
+ # it in /usr/share/doc/${PF}
+ mv "${ED%/}/usr/share/bbtools/bbtoolsrc.in" \
+ "${ED%/}/usr/share/doc/${PF}/bbtoolsrc.example" || die
+}