summaryrefslogtreecommitdiff
path: root/x11-misc/bbrun/bbrun-1.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/bbrun/bbrun-1.6-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/bbrun/bbrun-1.6-r1.ebuild')
-rw-r--r--x11-misc/bbrun/bbrun-1.6-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/bbrun/bbrun-1.6-r1.ebuild b/x11-misc/bbrun/bbrun-1.6-r1.ebuild
new file mode 100644
index 000000000000..c4340fdd041d
--- /dev/null
+++ b/x11-misc/bbrun/bbrun-1.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="blackbox program execution dialog box"
+HOMEPAGE="http://www.darkops.net/bbrun"
+SRC_URI="http://www.darkops.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ x11-libs/libXpm
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-list.patch
+}
+
+src_compile() {
+ emake -C ${PN} CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin ${PN}/${PN}
+ dodoc Changelog README
+}