summaryrefslogtreecommitdiff
path: root/x11-misc/autorandr/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-20 14:00:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-20 14:00:29 +0100
commit40a480a83a10d1718e26a6f4fc54d271c1f13a95 (patch)
treebfe08ce789f69c5862fd8e5d1bc17b22f9f21b86 /x11-misc/autorandr/files
parent2eda3a3b8ebdb3fc8552feb6f49e466d3bc8e88c (diff)
gentoo auto-resync : 20:10:2022 - 14:00:29
Diffstat (limited to 'x11-misc/autorandr/files')
-rw-r--r--x11-misc/autorandr/files/autorandr-Makefile-fix-install_udev-target-by-s-TARGETS-MAKECM.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/autorandr/files/autorandr-Makefile-fix-install_udev-target-by-s-TARGETS-MAKECM.patch b/x11-misc/autorandr/files/autorandr-Makefile-fix-install_udev-target-by-s-TARGETS-MAKECM.patch
new file mode 100644
index 000000000000..ff3b31d01326
--- /dev/null
+++ b/x11-misc/autorandr/files/autorandr-Makefile-fix-install_udev-target-by-s-TARGETS-MAKECM.patch
@@ -0,0 +1,28 @@
+From 4b8d397fc7a0d22a51ee13428ae13d892c0cc911 Mon Sep 17 00:00:00 2001
+From: Florian Schmaus <flo@geekplace.eu>
+Date: Thu, 20 Oct 2022 10:48:54 +0200
+Subject: [PATCH] Makefile: fix install_udev target by s/TARGETS/MAKECMDGOALS/
+
+A Gentoo user reported [1] that the 'install_udev' target would
+install a systemd-flavored udev rules, despite the 'systemd' target
+not being selected. Replacing 'TARGETS' with 'MAKECMDGOALS' in the
+Makefile rule fixes this .
+
+I am not sure where the TARGETS variable origniates from, but GNU make
+uses MAKECMDGOALS (FreeBSD make uses .TARGETS, i.e., with a leading
+dot). So if further portability between make variants is required,
+then this needs to be adjusted.
+
+1: https://bugs.gentoo.org/803545#c3
+Fixes: ae1f18a06039 ("udev rule: Dynamically call either systemd or autorandr directly depending on whether systemd unit is available")
+--- a/Makefile
++++ b/Makefile
+@@ -129,7 +129,7 @@ endif
+ install_udev:
+ $(if $(UDEV_RULES_DIR),,$(error UDEV_RULES_DIR is not defined))
+ mkdir -p ${DESTDIR}/${UDEV_RULES_DIR}/
+- echo 'ACTION=="change", SUBSYSTEM=="drm", RUN+="$(if $(findstring systemd, $(TARGETS)),/bin/systemctl start --no-block autorandr.service,${PREFIX}/bin/autorandr --batch --change --default default)"' > ${DESTDIR}/${UDEV_RULES_DIR}/40-monitor-hotplug.rules
++ echo 'ACTION=="change", SUBSYSTEM=="drm", RUN+="$(if $(findstring systemd, $(MAKECMDGOALS)),/bin/systemctl start --no-block autorandr.service,${PREFIX}/bin/autorandr --batch --change --default default)"' > ${DESTDIR}/${UDEV_RULES_DIR}/40-monitor-hotplug.rules
+ @echo
+ @echo "To activate the udev rules, run this command as root:"
+ @echo " udevadm control --reload-rules"