summaryrefslogtreecommitdiff
path: root/x11-misc/autocutsel/autocutsel-0.10.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /x11-misc/autocutsel/autocutsel-0.10.1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'x11-misc/autocutsel/autocutsel-0.10.1.ebuild')
-rw-r--r--x11-misc/autocutsel/autocutsel-0.10.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-misc/autocutsel/autocutsel-0.10.1.ebuild b/x11-misc/autocutsel/autocutsel-0.10.1.ebuild
new file mode 100644
index 000000000000..77f67d12b9ff
--- /dev/null
+++ b/x11-misc/autocutsel/autocutsel-0.10.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools
+
+DESCRIPTION="Synchronise the two copy/paste buffers mainly used by X applications"
+HOMEPAGE="https://www.nongnu.org/autocutsel/ https://github.com/sigmike/autocutsel"
+SRC_URI="https://github.com/sigmike/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXt
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}