summaryrefslogtreecommitdiff
path: root/x11-misc/arandr/arandr-0.1.10-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-08 13:29:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-08 13:29:57 +0100
commit4df758340c38fb7f188a6356561aeb4ed2c3f38c (patch)
tree751c69fba382d77b54ca38e9919abd415314405d /x11-misc/arandr/arandr-0.1.10-r3.ebuild
parent4cc852b4016d8aa1fa4d7a8b3911bebe1ed1da50 (diff)
gentoo auto-resync : 08:10:2022 - 13:29:57
Diffstat (limited to 'x11-misc/arandr/arandr-0.1.10-r3.ebuild')
-rw-r--r--x11-misc/arandr/arandr-0.1.10-r3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-misc/arandr/arandr-0.1.10-r3.ebuild b/x11-misc/arandr/arandr-0.1.10-r3.ebuild
new file mode 100644
index 000000000000..ead8fd0956c0
--- /dev/null
+++ b/x11-misc/arandr/arandr-0.1.10-r3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Another XRandR GUI"
+HOMEPAGE="https://christian.amsuess.com/tools/arandr/"
+SRC_URI="https://christian.amsuess.com/tools/arandr/files/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~ppc64 x86"
+
+RDEPEND="
+ dev-python/pygobject:3=[${PYTHON_USEDEP},cairo]
+ x11-libs/gtk+:3[introspection]
+ x11-apps/xrandr
+"
+BDEPEND="dev-python/docutils[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${PN}-0.1.10-manpages.patch" )