summaryrefslogtreecommitdiff
path: root/x11-misc/appmenu-gtk-module/appmenu-gtk-module-0.7.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 14:31:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 14:31:38 +0100
commit9c26151d84a72781f240cc7ca3e2f0ab4ba60f74 (patch)
tree4ac39398cd519351bf12c6357e7474c508f19d13 /x11-misc/appmenu-gtk-module/appmenu-gtk-module-0.7.6.ebuild
parentb99d693f4d27fe2eb2237a0fe7e9c3b87d4d6df5 (diff)
gentoo auto-resync : 17:07:2022 - 14:31:38
Diffstat (limited to 'x11-misc/appmenu-gtk-module/appmenu-gtk-module-0.7.6.ebuild')
-rw-r--r--x11-misc/appmenu-gtk-module/appmenu-gtk-module-0.7.6.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/appmenu-gtk-module/appmenu-gtk-module-0.7.6.ebuild b/x11-misc/appmenu-gtk-module/appmenu-gtk-module-0.7.6.ebuild
new file mode 100644
index 000000000000..8cfa793babbc
--- /dev/null
+++ b/x11-misc/appmenu-gtk-module/appmenu-gtk-module-0.7.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson systemd
+
+DESCRIPTION="Application menu module for GTK"
+HOMEPAGE="https://gitlab.com/vala-panel-project/vala-panel-appmenu"
+SRC_URI="https://gitlab.com/vala-panel-project/vala-panel-appmenu/uploads/e0b6a32a340922cd05060292b0757162/${P}.tar.xz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="gtk2 wayland"
+
+RDEPEND="
+ dev-libs/glib[dbus]
+ >=x11-libs/gtk+-3.22.0:3[wayland=]
+ gtk2? ( >=x11-libs/gtk+-2.24.0:2 )
+"
+DEPEND="${RDEPEND}
+ wayland? ( dev-libs/wayland )
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-automagic-gtk.patch"
+ "${FILESDIR}/${P}-no-automagic-unitdir.patch"
+ "${FILESDIR}/${P}-fix-pkgconfig.patch"
+)
+
+src_configure() {
+ # outputs [ '2', '3' ] OR [ '3' ]
+ local gtks="[$(usex gtk2 " '2'," '') '3' ]"
+
+ meson_src_configure -Dgtk="${gtks}" -Duserunitdir="$(systemd_get_userunitdir)"
+}
+
+src_install() {
+ meson_src_install
+
+ exeinto /etc/X11/xinit/xinitrc.d
+ newexe "${FILESDIR}"/${PN} 85-${PN}
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}