summaryrefslogtreecommitdiff
path: root/x11-misc/3dfb/3dfb-0.6.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/3dfb/3dfb-0.6.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/3dfb/3dfb-0.6.1-r1.ebuild')
-rw-r--r--x11-misc/3dfb/3dfb-0.6.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-misc/3dfb/3dfb-0.6.1-r1.ebuild b/x11-misc/3dfb/3dfb-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..a4c1a38b6260
--- /dev/null
+++ b/x11-misc/3dfb/3dfb-0.6.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="3D File Browser"
+HOMEPAGE="https://sourceforge.net/projects/dz3d/"
+SRC_URI="mirror://sourceforge/dz3d/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="dev-libs/glib:2
+ media-libs/freeglut
+ virtual/opengl
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README WISHLIST )
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-gcc41.patch" \
+ "${FILESDIR}/${P}-freeglut-compat.patch"
+ epatch_user
+}