summaryrefslogtreecommitdiff
path: root/x11-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-07 01:47:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-07 01:47:32 +0000
commitf0582d2144b45247a9a3e72569c44ca9539c0f4a (patch)
tree2d8e5a76fa75b9eb31410f2b077b45cc8bb8fdc3 /x11-libs
parentd0283dc748c38f55706c7e4c04f4848afeef54a9 (diff)
gentoo auto-resync : 07:03:2025 - 01:47:32
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/Manifest.gzbin17659 -> 17654 bytes
-rw-r--r--x11-libs/libnotify/Manifest2
-rw-r--r--x11-libs/libnotify/libnotify-0.8.4.ebuild71
-rw-r--r--x11-libs/wxGTK/Manifest2
-rw-r--r--x11-libs/wxGTK/wxGTK-3.2.5.ebuild4
5 files changed, 76 insertions, 3 deletions
diff --git a/x11-libs/Manifest.gz b/x11-libs/Manifest.gz
index a2ea5afa9562..3fc780357ea0 100644
--- a/x11-libs/Manifest.gz
+++ b/x11-libs/Manifest.gz
Binary files differ
diff --git a/x11-libs/libnotify/Manifest b/x11-libs/libnotify/Manifest
index 3de5bc119a8e..375723d6b112 100644
--- a/x11-libs/libnotify/Manifest
+++ b/x11-libs/libnotify/Manifest
@@ -1,3 +1,5 @@
DIST libnotify-0.8.3.tar.xz 106008 BLAKE2B 05852c866dc91d42cf01804333605ecb546f7d779b143fabc341752263c8cacea9acda40bb60af90dbc84ab8327ba99966e09924ccc337f7a97909b95d39a874 SHA512 e55073fdf418a4c04375825221edc92ab6a01201b83db2a1f1530f8f91f7da9da32327452b0785251790553517dcc717cfe623142450691b7dd247ec9164cffb
+DIST libnotify-0.8.4.tar.xz 107396 BLAKE2B 463ac3395ec79cfeb1a7e4584905bb36a708e30700a6acaf28413f45bf2b86fb0df3e8beeacb6f8a01d49ab6940382ef58d4bae62a2d9769dd5ee2f047be2429 SHA512 b13163a3b787133700931077591debc9cb89ac917f8fcf46bfb58bcf7eae348601b1e03299786d9af368139278b128424919358a8e7d208621f8b350fd063b0a
EBUILD libnotify-0.8.3.ebuild 1663 BLAKE2B 4c160976867f2ec486c2c871b4400287ed1bbbf4f7670c47952ca9ad8a80c2b78c24a8cb3dc68ee41853e311c7d0133c880729e5c3783160599007b62b26e569 SHA512 c35f9e353b9531f242a614164a2bf3409298f6ec660654e66dab452df4f8183e6d53bdf554f4f35a2048dd7c89ee4c9e1ec175f77dced9c4182f25c61ab88bcb
+EBUILD libnotify-0.8.4.ebuild 1670 BLAKE2B 09162ca424a916fde0204584596ba6097d9f2defd32d232817e79d00f358d582e1e1ea592f3359d03b3be50dbecda273e16a25eb4c9642c1a465c20e85852247 SHA512 c6f90b2119cfb6bf743f4c41204a2cbf5f23320378fa7f2401d4a66054954978bbbe5f1634387740c3abe48d5a4486747a6dea98bce46f49b038f55425a3c327
MISC metadata.xml 487 BLAKE2B 9ca610c8e5775a9daf61254bdf6364bf8e2df0646c48c78e1178b5232faa1711c7a2cc85943dc8078b92c59b3d4d2a65525d4adc60d2fc323048c264b9495996 SHA512 7f1d6337756480c08fb487ec9115fe2ed7b7cae248fdb751fb3cb49c301807deb02b879e3ec8c275bef87d33c8eb853d6f9a16d72e6fcafb47446d8f634b2fa9
diff --git a/x11-libs/libnotify/libnotify-0.8.4.ebuild b/x11-libs/libnotify/libnotify-0.8.4.ebuild
new file mode 100644
index 000000000000..e05a80fe160d
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.8.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson-multilib xdg-utils
+
+DESCRIPTION="A library for sending desktop notifications"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libnotify"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="gtk-doc +introspection test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="gtk-doc? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.62:2[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[introspection?,${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-libs/gobject-introspection-common-1.32
+ dev-util/glib-utils
+ virtual/pkgconfig
+ app-text/docbook-xsl-ns-stylesheets
+ dev-libs/libxslt
+ gtk-doc? (
+ dev-util/gi-docgen
+ app-text/docbook-xml-dtd:4.1.2
+ )
+ test? ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )
+"
+IDEPEND="app-eselect/eselect-notify-send"
+PDEPEND="virtual/notification-daemon"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ $(meson_native_use_feature introspection)
+ $(meson_native_use_bool gtk-doc gtk_doc)
+ -Ddocbook_docs=disabled
+ )
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ mv "${ED}"/usr/bin/{,libnotify-}notify-send || die #379941
+
+ einstalldocs
+
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/{doc,gtk-doc}/libnotify-0 || die
+ fi
+}
+
+pkg_postinst() {
+ eselect notify-send update ifunset
+}
+
+pkg_postrm() {
+ eselect notify-send update ifunset
+}
diff --git a/x11-libs/wxGTK/Manifest b/x11-libs/wxGTK/Manifest
index 7b61d379eb42..b483af409f71 100644
--- a/x11-libs/wxGTK/Manifest
+++ b/x11-libs/wxGTK/Manifest
@@ -27,5 +27,5 @@ EBUILD wxGTK-3.0.5.1-r1.ebuild 5646 BLAKE2B e22efcae6b368013585697a04ac1172eab56
EBUILD wxGTK-3.0.5.1-r3.ebuild 6177 BLAKE2B 26582758e26d72f791697cd9bdbaf1e373d2876012ac4d5767e08d8b67cd6c2b78337e7b3def9f2debbba11ff64bf2de1a9e8078bb86d38f3367add65c498d4c SHA512 3a0ebc816aa2dc14b7a0d38bc0a8e5afa1166fb30350b6bb5a589afd2deebff5c968925e43720423e7fc33e972616e3abe2b8e7ead442f6cb6b669271720f3f8
EBUILD wxGTK-3.2.2.1-r5.ebuild 8405 BLAKE2B 0ae0751334b5920ec4ee9d1f801e8e87f515a0a36c0142c573bb8f27a8db31417150f8e817bd071026461a0955823e8c4411fbff569192f877e4698799e7d016 SHA512 83ffb85d1c03715fdcc20e32408b358205110fc756883c73b8cc0dae5aa917582c11e41cc4dc812a1c7d1d80240c9119f50bb447f1de389235196868368477cd
EBUILD wxGTK-3.2.5-r1.ebuild 8412 BLAKE2B 55c1855da7ed8415b3a6fa74157bc3ce412b1614e2a57824445fcb9cfa0d3a31e2006918595a447541a8bb8ba6679fcba195af230275aac98fab2948043db881 SHA512 ddb3d534a92330156f6fcbaddab7da9b1ec9e17f6e1345915eb5c2c004a08851a5b9d51a767596f1d6e0930b0dfdb2d10ff75abb6c34bfed5fc39b15f0165ca4
-EBUILD wxGTK-3.2.5.ebuild 8242 BLAKE2B e682fbae5c1cc9cbbbefdd2a2b5f9b126eb93db44e169801558f163f107a1e93dabfa6f8f0fc4a15de50858e19ac033d2c1e4d71c5024f032b5053300674ab27 SHA512 017f76e3f0a11e4c7b5677402668e8832d57cbb8cd11ceb1eeb606126201bb723d43c8136a16633bbfd61fecf24355b1ae68d1fc349b72c485dd97e6c127fe06
+EBUILD wxGTK-3.2.5.ebuild 8240 BLAKE2B 1c0db626cb1a9d22aa312fa85fdceeb35ff0c9f08afa7a646d8250d8715b232a85a553e5d8b6ea1ed661bbafcdad4cfc4657dfb12e59ec90de1c62a5435c05fb SHA512 7dee48240944a6106fe4177b9c7f18533b8ab392f7a4bf160e551160d04c0b17cac4e396991962c4cc91eab874e1057a3f2e3bee6bbe267536dc736e4ef08d31
MISC metadata.xml 756 BLAKE2B 336ffb3375ee9092de02d0808d0a44f7f5bcbc6e4a845c12b6466af0b91f3397c2b335e5433917361a060db43d6cb836cde0f87be2059214f314fa6726199e2d SHA512 190b72992c64b43b46e28ca2f730e1897a5f740ba211b859c816b4892256284feb579fbce06cb1939b774ae989dc68754f5a57f6375cfca50d7770d0c2ed47ed
diff --git a/x11-libs/wxGTK/wxGTK-3.2.5.ebuild b/x11-libs/wxGTK/wxGTK-3.2.5.ebuild
index 6a65c97507ac..42e698eb1ea0 100644
--- a/x11-libs/wxGTK/wxGTK-3.2.5.ebuild
+++ b/x11-libs/wxGTK/wxGTK-3.2.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,7 +20,7 @@ S="${WORKDIR}/wxWidgets-${PV}"
LICENSE="wxWinLL-3 GPL-2 doc? ( wxWinFDL-3 )"
SLOT="${WXRELEASE}"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~loong ~mips ppc ~ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ~ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
IUSE="+X curl doc debug keyring gstreamer libnotify +lzma opengl pch sdl +spell test tiff wayland webkit"
REQUIRED_USE="test? ( tiff ) tiff? ( X ) spell? ( X ) keyring? ( X )"
RESTRICT="!test? ( test )"