summaryrefslogtreecommitdiff
path: root/x11-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-11 18:45:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-11 18:45:56 +0000
commit72d7e048ae88be323a380e2eae52dfda0b2dc1c0 (patch)
treee3d45f3a557c324e6058aae95f920e55d8f40602 /x11-libs
parent8b4349b75818953123e2d4b80963181a9640c8e3 (diff)
gentoo auto-resync : 11:03:2024 - 18:45:56
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/Manifest.gzbin18011 -> 18005 bytes
-rw-r--r--x11-libs/libXaw/Manifest2
-rw-r--r--x11-libs/libXaw/libXaw-1.0.16.ebuild35
3 files changed, 37 insertions, 0 deletions
diff --git a/x11-libs/Manifest.gz b/x11-libs/Manifest.gz
index 83fb6e4745dd..3f5e538142ad 100644
--- a/x11-libs/Manifest.gz
+++ b/x11-libs/Manifest.gz
Binary files differ
diff --git a/x11-libs/libXaw/Manifest b/x11-libs/libXaw/Manifest
index 719d9acf283e..4b9871d088f3 100644
--- a/x11-libs/libXaw/Manifest
+++ b/x11-libs/libXaw/Manifest
@@ -1,3 +1,5 @@
DIST libXaw-1.0.15.tar.xz 589832 BLAKE2B a176b59fbbd7555e7ec2f114a31e9ed804c0ee9e2f7f0efc1ed836caa280947bbe1c66dc4b5155f983a91b649a6303730377b5203d17dcd6af8dfdfa51e7784c SHA512 8edbf280b7b24b9040c291545053c1251d6af7e7f56da43a6065a1848245863eb52bdfc28c2f18dbb6597a4064394a44f4df5d8596a1a467549ccc9ce50a7821
+DIST libXaw-1.0.16.tar.xz 602848 BLAKE2B 342ca47da7fce2ddcc01b12bff6b279ad1ce6a743e3d6cf20120a98d67cc8c533d0c19c33250552d8709c8fc401e72147b04522e9ced998b05b7639a15115e23 SHA512 1cabad1a9b06dec7de601b977e844536823ee1a0045244acc42ca6b6107da9b4953736d94898a96cab40845eab77dae21e20e1fa66a3dfc4dedf575dfbca04aa
EBUILD libXaw-1.0.15-r1.ebuild 857 BLAKE2B 263070219dc5d6790998c9521d44f650ca9c62302b26e4a791d510dadea1f54a16ec592964abf2810dffa0ee1d2854efd2256cb48e90476fffd7753431e1acd9 SHA512 af7e4477b2a13cd0c865785fb5472ede8d67fdf30cd772e839b3fb97fb78f8e97f480a68f2c66a157f2670b0a0dfed5ea810890b490f75a08f63b9d7215afd65
+EBUILD libXaw-1.0.16.ebuild 864 BLAKE2B b1e25addcf02cb85129621dfb831484bd67d59639d5d46f39511e76f60e948b0af2c4dd284d282cfae89d2e032d001a29b10fdfcb8ddc2f68d17f40e167de41b SHA512 0a9f5b2b5ea89fd42a441cb7c6b7b71d4308cff06d868809e3482afd643940e6e5c8254e00beb6dec31f020172540712b4e5ca7d4bb65386b8453a1a2249d59d
MISC metadata.xml 422 BLAKE2B b5d0b66e0f4638f8e8969f8fe1c02f4d83195f11529b266e2f79f18b71f2407102545a4e55b318c4a0957cbf00570586626a9a8ce3cda99bc463c0246ed7bcce SHA512 56d9ac54daf5febd8fc3df76ce86974b6ab37130bdb80d84ad07b59d985d6d1337afff0b36bafadad9ba464e7cbd45a7d6f71f697be3b66f9db907b317d9c2a8
diff --git a/x11-libs/libXaw/libXaw-1.0.16.ebuild b/x11-libs/libXaw/libXaw-1.0.16.ebuild
new file mode 100644
index 000000000000..22493f2c8cfc
--- /dev/null
+++ b/x11-libs/libXaw/libXaw-1.0.16.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Xaw library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="deprecated"
+
+RDEPEND="
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXpm-3.5.10-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable deprecated xaw6)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}