summaryrefslogtreecommitdiff
path: root/x11-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-14 02:02:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-14 02:02:08 +0000
commit59d772d9463f8cf6a145a677bedbf377a0625aff (patch)
tree5a0e382968fd656a056c886e36cfb4491535b489 /x11-libs
parent2a3e0d61b3d88306b6fae46756f9ba7d230222ae (diff)
gentoo auto-resync : 14:12:2024 - 02:02:07
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/Manifest.gzbin17869 -> 17868 bytes
-rw-r--r--x11-libs/libICE/Manifest2
-rw-r--r--x11-libs/libICE/libICE-1.1.2.ebuild28
-rw-r--r--x11-libs/libSM/Manifest2
-rw-r--r--x11-libs/libSM/libSM-1.2.5.ebuild62
-rw-r--r--x11-libs/libXrender/Manifest2
-rw-r--r--x11-libs/libXrender/libXrender-0.9.12.ebuild17
-rw-r--r--x11-libs/xtrans/Manifest4
-rw-r--r--x11-libs/xtrans/xtrans-1.5.0.ebuild22
-rw-r--r--x11-libs/xtrans/xtrans-1.5.1.ebuild22
10 files changed, 113 insertions, 48 deletions
diff --git a/x11-libs/Manifest.gz b/x11-libs/Manifest.gz
index e03776a671d0..c1b0f3c30043 100644
--- a/x11-libs/Manifest.gz
+++ b/x11-libs/Manifest.gz
Binary files differ
diff --git a/x11-libs/libICE/Manifest b/x11-libs/libICE/Manifest
index cc1461163f96..887c7b1a1a1d 100644
--- a/x11-libs/libICE/Manifest
+++ b/x11-libs/libICE/Manifest
@@ -1,3 +1,5 @@
DIST libICE-1.1.1.tar.xz 335960 BLAKE2B 2849418aa0a66a9137481194bb91208fae4a1eb9a4f9f509b52da7668b8281b6c36f4ba4bdc686eb008a2561b89801fb9270b22887b7c5044e6c14a1ae94dfae SHA512 2f7833a25f31cc743ca95cb88f9a8403b50e19ffb5bf43bfef87ba405857d359789daaa9ec2391351237d958f16d35dbf082adb76d301e46d3a54162a6b452d3
+DIST libICE-1.1.2.tar.xz 342900 BLAKE2B 8dbfb61382009397260415a68a74dd27e277815b22000a617fc688cf12257293de8e29a69df91e88dcae93e14f193bf653ed8dee747b4c2bf5493a509ed9b937 SHA512 340f51ffa1f14ed442ab8bcea92dd63df147c48242e232e818cafe02f43de7ab6e99c5430b9cb8d0dc661295239d2b3f6bdb6a092ce51a98afa06235257e9b1f
EBUILD libICE-1.1.1-r1.ebuild 621 BLAKE2B 33adfe3b62861365b7dfa5a74c747864c0a1e81c030313175022e924d938062aa807e297fd990647f872e4a7f8dded5407f88ceed7cbdaaf4b341dc1b0d72f88 SHA512 63fa09404e53b0fa9c24ae6736b241a0de219c0dbd86ffb2478af89abacee245934b0ad2900d6396d2153f855fcf13b4be54e11c18102a2fcc7918238c34a492
+EBUILD libICE-1.1.2.ebuild 629 BLAKE2B 20f15ca1c0816ea8e98ff32ffe2679d1bb1029e540182a3b2eababc3f700f9100e0a6d5bfb60ee5fa348b0f840ddde8289a23691f0d642f41f2d244b3ab6df18 SHA512 ea1affb0f5de482ce75324abca8365670e7292244c57e4163844bc74bf4a4c2de1da5caad7fd8928e237ff408fc67bf5d4f38e3c128c2ff4a75e20397bc013c2
MISC metadata.xml 337 BLAKE2B c895594110c07848bd58cf4a28df82dbdc5f26671689386a667afd32f3925d4b401887d992282416213be51536ee4d24fd00c0f85d52c98eb71d66854209055b SHA512 2718c47a51ba70e9622bd3bf5e6d987fa2f57d122e25aa972f71585ddf3dbdb8bf34eaa0492846e6230d951f8d557948e1d7e3f54ee27765b63e8f9f2e6fe604
diff --git a/x11-libs/libICE/libICE-1.1.2.ebuild b/x11-libs/libICE/libICE-1.1.2.ebuild
new file mode 100644
index 000000000000..081a9ec6628e
--- /dev/null
+++ b/x11-libs/libICE/libICE-1.1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Inter-Client Exchange library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ elibc_glibc? (
+ || ( >=sys-libs/glibc-2.36 dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans
+"
+
+XORG_CONFIGURE_OPTIONS=(
+ --enable-ipv6
+ --disable-docs
+ --disable-specs
+ --without-fop
+)
diff --git a/x11-libs/libSM/Manifest b/x11-libs/libSM/Manifest
index 5bc1b26becec..3139e1a340bd 100644
--- a/x11-libs/libSM/Manifest
+++ b/x11-libs/libSM/Manifest
@@ -1,3 +1,5 @@
DIST libSM-1.2.4.tar.xz 306944 BLAKE2B c1944cd8e25389cffc18e9f6e46e3543381a2d74036cff2c24f063c1defca001c94055ef278dc468123b1f60f145df5daf34bcec39875ad918b664a3c279777a SHA512 7f1d41b7b6c5dd456c49ccad7740c3ba9791a2793fa50fd94814a4164ce2e20c4a0a0ad42a87708e494ed5c23f611be6d3ccd9ef1e9add6d46ac545e2b0f6f86
+DIST libSM-1.2.5.tar.xz 312708 BLAKE2B 9babbc5409037d1292c85c0b23ff21975f614e9cfe53c6878761e67489815862a98ef84a2249161279fd5d7af7ff886cfbafb63b82832ee142e513e3d359e6cd SHA512 f2e58503a7cd144a610621104b4727878dd5ba0cdf8220e72f27a3474c9b49c01dc514c60cbdfb35a9318f307b27a601580725cef0f6b5091d4c4ea57cef8c91
EBUILD libSM-1.2.4.ebuild 1673 BLAKE2B a1aa9b0eb9f2107080f7c4f4b10f7653e30154aa9cd77f968a2e45b93be432d5390fb2bdfbb41696d9c3708901c74d4eb150550c8e51dfcb5513be1192cb26b3 SHA512 7bf3eb26b78a44d37862b055c4381177bfa9b696ce25027bdc285e2182982f275511b30388054d9d0eb5264c298250295acc52ad8e012a048391515d4f9182d1
+EBUILD libSM-1.2.5.ebuild 1681 BLAKE2B 97bdab30a18e273f64517ddcd5dbf0088f2c66a373f394c7a548da7716fe965ea29910d7be6d1335174f9b33e97e3c3512dd87405e0e9d546de87cef3dca3620 SHA512 fa0bb43e558c94a36470ec469d1f41eb4705f02d29262907bfc8a3c8d402a2ea9a78db9d3dd20098cfe70eb1f3f2b45a19849e11f6a6da1d82d18f95f864aa13
MISC metadata.xml 457 BLAKE2B 895411214399309db731cd3f1c5c49ec5a505aa4a7a03e9fc39e7027b1956aeae7b0ffebe1d6f4500eaba907c0aa2ce7332f56de0b53ebc26dd000835a29c9ce SHA512 9e810808a715e91e939d710c5633675d4a7d74b2a18d8054d1932f6022bf186ae981b1ffffd81893bb1959923ddf541908a24656e7c308589994178dbab9ff60
diff --git a/x11-libs/libSM/libSM-1.2.5.ebuild b/x11-libs/libSM/libSM-1.2.5.ebuild
new file mode 100644
index 000000000000..7d919fb6e3c2
--- /dev/null
+++ b/x11-libs/libSM/libSM-1.2.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Session Management library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="+uuid"
+
+RDEPEND="
+ >=x11-libs/libICE-1.1.0[${MULTILIB_USEDEP}]
+ uuid? (
+ elibc_Darwin? ( sys-libs/native-uuid )
+ !elibc_SunOS? ( !elibc_Darwin? (
+ >=sys-apps/util-linux-2.24.1-r3[${MULTILIB_USEDEP}]
+ ) )
+ )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/xtrans"
+
+src_configure() {
+ local withuuid=$(use_with uuid libuuid)
+
+ # do not use uuid even if available in libc (like on FreeBSD)
+ use uuid || export ac_cv_func_uuid_create=no
+
+ if use uuid ; then
+ case ${CHOST} in
+ *-solaris*|*-darwin*)
+ if [[ ! -d ${EROOT}/usr/include/uuid ]] &&
+ [[ -d ${ROOT}/usr/include/uuid ]]
+ then
+ # Solaris and Darwin have uuid provided by the host
+ # system. Since util-linux's version is based on this
+ # version, and on Darwin actually breaks host headers when
+ # installed, we can "pretend" for libSM we have libuuid
+ # installed, while in fact we don't
+ withuuid="--without-libuuid"
+ export HAVE_LIBUUID=yes
+ export LIBUUID_CFLAGS="-I${ROOT}/usr/include/uuid"
+ # Darwin has uuid in libSystem
+ [[ ${CHOST} == *-solaris* ]] && export LIBUUID_LIBS="-luuid"
+ fi
+ ;;
+ esac
+ fi
+
+ local XORG_CONFIGURE_OPTIONS=(
+ --enable-ipv6
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ ${withuuid}
+ --without-fop
+ )
+ xorg-3_src_configure
+}
diff --git a/x11-libs/libXrender/Manifest b/x11-libs/libXrender/Manifest
index 9c96098978f0..70c338b43604 100644
--- a/x11-libs/libXrender/Manifest
+++ b/x11-libs/libXrender/Manifest
@@ -1,3 +1,5 @@
DIST libXrender-0.9.11.tar.xz 302900 BLAKE2B b603118a02bc0bd64a98ac9820e6fd46a0613441b630d10aa8955c3a5e364c283f3d7323f7cd64e6c3a4c599409ae9d7c847751edc3250946342008abb66a015 SHA512 2327cc1b530382d81df29b8d579f801f1f990202107cc84506986bcf5d15010d414e9418987b200e3f222d188afce46f0d7754febcdca62a5fc1e541b3bb82de
+DIST libXrender-0.9.12.tar.xz 310432 BLAKE2B 703f32aabc074097796ecf97933fd9eb74aca4794496ae5d62fac3cef8646d41fffa8904ac3e76735473f918fa65e9c3da16e54ac512c45f2b00592e8e46dff1 SHA512 3d24a6877b500608e3e2a393532a99d4fd54fc343375d8fb51dfbb1b50cedf002c7722f771cf7776f93cb6e0421ca5966ce45435cb402d5f12a398f9ea743474
EBUILD libXrender-0.9.11.ebuild 457 BLAKE2B 07652e4dc60484701e6e0ccf53bdd4437ea2438626bd663f4cffe50cd67ef75d639a33a15affdb58ae6e54458cf0148032372e071b4e639c3e6c7db21021f610 SHA512 c9bdbc98e7a6e18752d8d6eba2cbc935def8e9fcaf6e16c64d28700d6089bc1930e461b7cfcef81dab28470b5e0fc8dc3dd4aa51b16c631770f9eb7d42b7921c
+EBUILD libXrender-0.9.12.ebuild 465 BLAKE2B 31360f2bf54212994d8fc331284d5c00885513a1df19361ca4f19883ef6ad78617c7b9e3af405078a09b07e96cf2b69ee8fc5e6373e2117c05d8ec30b2418336 SHA512 6c5e35aade1ed313dd1096186a647140c89177d6a29778859fa7710977b3eb02f76f1ff7362abf47ff26b2e690ba6c3e4bcf7b1698caa954545144dca85720e2
MISC metadata.xml 341 BLAKE2B 02c79694315c5ca33c90a8854cbf506addc7b69a68fe066f99a45c3fbe7764ebc69c03808215e056c2bd0f7b0261ec173d02a623e8c91c3a090b9ae77a1c83a8 SHA512 158a1a560ef016f8fd5c85a6dc65fae5ce9e960f65be43913a58a4218b2f24ef4cd925a490140f8463b206fb50d5c18243c9dc0ea56b0639f5ad9e5fbc0cb31c
diff --git a/x11-libs/libXrender/libXrender-0.9.12.ebuild b/x11-libs/libXrender/libXrender-0.9.12.ebuild
new file mode 100644
index 000000000000..37ee18e62f47
--- /dev/null
+++ b/x11-libs/libXrender/libXrender-0.9.12.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Xrender library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
diff --git a/x11-libs/xtrans/Manifest b/x11-libs/xtrans/Manifest
index ecb79f92e5f8..a20a52d21692 100644
--- a/x11-libs/xtrans/Manifest
+++ b/x11-libs/xtrans/Manifest
@@ -1,7 +1,3 @@
-DIST xtrans-1.5.0.tar.xz 170388 BLAKE2B a07dc501a36f4a6d7d9c407c36c5fcaa9555eeec3066d91fa8531118ac04bc55a1fbdce6370782aa8a18e1f26b14e3ad644e1e98ae3a353234e3ecae71fe065b SHA512 e8091f11d4ad2b14e01de3eac56bdf2267ea26687ce66e3056374d0d02e049480c0b27c482f8828a0efd086f1e4c485108ca4dce3f83d66c1896effa3b38b228
-DIST xtrans-1.5.1.tar.xz 175624 BLAKE2B 5ab6ffdc0028da16b4373f824c9bfc51db9bb90bc593c101b2647496846687fd020423e4eb204e8b261fa39123f5a57338b9257b13b7abb92e8d1a49cd3c3345 SHA512 1a4bf3495ba401711b632972acf26bb82c2e8fd917a868ed21e510a1bb1ec57c145496baddb44de76e00c2d03dbf9e8592099623da4c065de3a7c5a804e87c1e
DIST xtrans-1.5.2.tar.xz 176680 BLAKE2B 6381257bfc489767438e76afe9bab5e9f143e7524417de0396c0d04e42f1ee7ef28cec6fee83a68f60d3d82326c824f1baa9e58c47f7108e4a4d5dc9a2daa65a SHA512 4c4909402cb7df0d69bf2801722de822f7e376d585ff5aa8db8f88be77ed7fb7dfbdc410827069fc5041327e81afeb9d403c6c92e5c1e02d593c829ef6c37536
-EBUILD xtrans-1.5.0.ebuild 588 BLAKE2B 508b3ad507e8fa27de824a75b3906f91b92a6fc08d572d3a3a3c24b332c6f067745b5fa2485599b251abc8bdd20f26ca0987e1eb8dfe3e7b32d570f336bda306 SHA512 97ae0117d2d993145c9345d108fd7166b27efd22f6baa07ec1e540b95f3af893603d029ea71a7e52c2985b5ea2b6fd959911bd6ed1b08aa7e0673b87c58a8efe
-EBUILD xtrans-1.5.1.ebuild 589 BLAKE2B ff2c2141b98cc891f51a9d3c100426839ea8ff488bba8845f999bdf40ef51f112fa747be361015e9baaf69ca1084d6ca582a0a521d22547065ec7f7bf81347a1 SHA512 155c4e86a7ce2bd8038d103f6185f93321c4a5a925b6a4941c5e30cad0347364a6e9ac1faa182997fa4dd318c3a391a048a0648d36ac5d2538f218b75c2ca69c
EBUILD xtrans-1.5.2.ebuild 588 BLAKE2B f859cc8cc1a6c6317c702fc6382c5c588ce374e4c9d14c217abdd6791fd69d446100882fcf60baef404721b7577b278d625b95e16b18d80311022387fcfcb12b SHA512 6d1ff25ed9dcbf70637f4a0db70be41fcb2e75bb08e8e43983d657a52a3a53f5a712eb137fd0bf7d4947a681035c77b9b70ab9ba20269d03e7ed94e5539ebc4a
MISC metadata.xml 340 BLAKE2B a338aaec9199c9b8d4d7104867c9beab0c1363cf8ae64b4c13366ba1d506a8849c9ace547c8ba8f737e5f0cb6f69a9acc11e4a7ed719bad81da5fb44214d33c4 SHA512 1a1504c0e5788a839e01bb8fa84ac557664af8057690b7dca4528253abbc6355bad2899c492a847ff1c4c938ffb2652c6d34a0b6f6efc2a783080a606ad8323e
diff --git a/x11-libs/xtrans/xtrans-1.5.0.ebuild b/x11-libs/xtrans/xtrans-1.5.0.ebuild
deleted file mode 100644
index e5050c583f96..000000000000
--- a/x11-libs/xtrans/xtrans-1.5.0.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-XORG_PACKAGE_NAME="lib${PN}"
-# this package just installs some .c and .h files, no libraries
-XORG_DOC=doc
-XORG_TARBALL_SUFFIX="xz"
-inherit xorg-3
-
-DESCRIPTION="X.Org xtrans library"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-
-src_configure() {
- local XORG_CONFIGURE_OPTIONS=(
- $(use_enable doc docs)
- $(use_with doc xmlto)
- --without-fop
- )
- xorg-3_src_configure
-}
diff --git a/x11-libs/xtrans/xtrans-1.5.1.ebuild b/x11-libs/xtrans/xtrans-1.5.1.ebuild
deleted file mode 100644
index bf61d4caccaf..000000000000
--- a/x11-libs/xtrans/xtrans-1.5.1.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-XORG_PACKAGE_NAME="lib${PN}"
-# this package just installs some .c and .h files, no libraries
-XORG_DOC=doc
-XORG_TARBALL_SUFFIX="xz"
-inherit xorg-3
-
-DESCRIPTION="X.Org xtrans library"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-
-src_configure() {
- local XORG_CONFIGURE_OPTIONS=(
- $(use_enable doc docs)
- $(use_with doc xmlto)
- --without-fop
- )
- xorg-3_src_configure
-}