summaryrefslogtreecommitdiff
path: root/x11-libs/xtrans/xtrans-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
commitcf7807d7aea23a99a144afceaba961cfed652b5f (patch)
treeffd2c781c27e0b7e72152a685a04938a2b7966f0 /x11-libs/xtrans/xtrans-1.6.0.ebuild
parent7c5ebaf83da4c538dd11b56fdd5dfdf39dcbc096 (diff)
gentoo auto-resync : 11:03:2025 - 01:49:36HEADmaster
Diffstat (limited to 'x11-libs/xtrans/xtrans-1.6.0.ebuild')
-rw-r--r--x11-libs/xtrans/xtrans-1.6.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/x11-libs/xtrans/xtrans-1.6.0.ebuild b/x11-libs/xtrans/xtrans-1.6.0.ebuild
new file mode 100644
index 000000000000..97f1c3166c6b
--- /dev/null
+++ b/x11-libs/xtrans/xtrans-1.6.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_PACKAGE_NAME="lib${PN}"
+# this package just installs some .c and .h files, no libraries
+XORG_DOC=doc
+inherit xorg-3
+
+DESCRIPTION="X.Org xtrans library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}