summaryrefslogtreecommitdiff
path: root/x11-libs/xcb-util-errors/xcb-util-errors-1.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-10 17:37:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-10 17:37:15 +0100
commitc7c8d625ecbe5f95c445995303ed9b0e1f0de507 (patch)
treef0e6e5b3d8a377cf309b6085c2c7a30e640f84a1 /x11-libs/xcb-util-errors/xcb-util-errors-1.0.1.ebuild
parentd6fe3a53bdeea6b060d1755199cc2c27492dc14c (diff)
gentoo auto-resync : 10:04:2023 - 17:37:14
Diffstat (limited to 'x11-libs/xcb-util-errors/xcb-util-errors-1.0.1.ebuild')
-rw-r--r--x11-libs/xcb-util-errors/xcb-util-errors-1.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-errors/xcb-util-errors-1.0.1.ebuild b/x11-libs/xcb-util-errors/xcb-util-errors-1.0.1.ebuild
new file mode 100644
index 000000000000..042df044f2f6
--- /dev/null
+++ b/x11-libs/xcb-util-errors/xcb-util-errors-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+XORG_TARBALL_SUFFIX="xz"
+inherit python-any-r1 xorg-3
+
+DESCRIPTION="Library that gives human readable names to XCB error, event, & request codes"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb-errors"
+
+KEYWORDS="~amd64"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1:="
+DEPEND="${RDEPEND}
+ x11-base/xcb-proto"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'x11-base/xcb-proto[${PYTHON_USEDEP}]')
+"
+
+python_check_deps() {
+ python_has_version "x11-base/xcb-proto[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ xorg-3_pkg_setup
+}