summaryrefslogtreecommitdiff
path: root/x11-libs/wxGTK
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /x11-libs/wxGTK
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'x11-libs/wxGTK')
-rw-r--r--x11-libs/wxGTK/Manifest1
-rw-r--r--x11-libs/wxGTK/wxGTK-3.0.4-r303.ebuild166
2 files changed, 167 insertions, 0 deletions
diff --git a/x11-libs/wxGTK/Manifest b/x11-libs/wxGTK/Manifest
index e8a13d910ecd..eb15934de24c 100644
--- a/x11-libs/wxGTK/Manifest
+++ b/x11-libs/wxGTK/Manifest
@@ -6,4 +6,5 @@ DIST wxWidgets-3.0.4-docs-html.tar.bz2 24122986 BLAKE2B ffd38d50e6cb44077f346597
DIST wxWidgets-3.0.4.tar.bz2 20204622 BLAKE2B 97b9f3f44f080104cae290bc3e162b51ce27a96fb22b191d52f30db1f1dc7951defcc220afc4dcb8417cfe23490762c2a25f62164ac21809f73ccf442dd19347 SHA512 c9e6b35d541a99921c54cfdac260843f574f146b27f924a7a0fca5007344fa99865a96ded95e6802329ad9221b4880d62b92277a1b4c1ce71420acb672ad9158
EBUILD wxGTK-3.0.4-r2.ebuild 3600 BLAKE2B 019f83f1fb028982123b691988bc1513fc7f71ef517e6fa696b693ca53baa88ce424c1c779c1904e75956d6629a5f42b1977a6ac2b1d78bd5a7533714cbc1976 SHA512 c687c3bcddaf4c934e1616651d982bd0b175db8eedb4babb6820a39503f1b6484dd2b219a685f12931f0937e427d2d068065d0247c364e6dfe55aae73655a66b
EBUILD wxGTK-3.0.4-r302.ebuild 4824 BLAKE2B bc5a1a4266fe8dad373ed7efc86ed6b4df84e119047146b2aceb2ddd085399184ff38b9bdf7adf1b1543f907db56d210a271e67d8ba025331802d453ae603207 SHA512 9d3c39b3a9c5350eb75f35822898f29f1e7941bb449ec8e1221edfd75a4c51bfd4649128163827c3ba76b1c23eba03444e00e45f519d4929fc6b417897d7e6bf
+EBUILD wxGTK-3.0.4-r303.ebuild 4929 BLAKE2B a88b9b5f2425073d28503e48feaffde017b8740270f1ccb2b5de25c89dada239a8938bc6d85767043d071a739c376b2748ab6a15be8d0fd123fa5ca3e4f0e89e SHA512 535ba5ee43e62bb46050bedb0b399233746bb7d366660876af40f891a1793e6e6174373c837e8279dc3136fbe0701606bd1d807708bccccf02693c5d7c28bb6d
MISC metadata.xml 759 BLAKE2B 4bafb6bd1d082eae5773d84fb116779f337e662090c4d01e22296f891114458de4a50f1f10775b61f06f22c6db7d4288c66c0c59836cc362298c23fecef499af SHA512 a7bf3b8cecf7ffba0dbfded9884fb7df3866c1a00c473f9ecb2d3fc1c84c5713dcde949f6acc35ee688741efb2da74fc189ed9c58b24bd2874c7e95908eb1f60
diff --git a/x11-libs/wxGTK/wxGTK-3.0.4-r303.ebuild b/x11-libs/wxGTK/wxGTK-3.0.4-r303.ebuild
new file mode 100644
index 000000000000..65d027d2d111
--- /dev/null
+++ b/x11-libs/wxGTK/wxGTK-3.0.4-r303.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+WXSUBVERSION=${PV}.0-gtk3 # 3.0.3.0-gtk3
+WXVERSION=${WXSUBVERSION%.*} # 3.0.3
+WXRELEASE=${WXVERSION%.*}-gtk3 # 3.0-gtk3
+WXRELEASE_NODOT=${WXRELEASE//./} # 30-gtk3
+
+DESCRIPTION="GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit"
+HOMEPAGE="https://wxwidgets.org/"
+SRC_URI="
+ https://github.com/wxWidgets/wxWidgets/releases/download/v${PV}/wxWidgets-${PV}.tar.bz2
+ https://dev.gentoo.org/~leio/distfiles/wxGTK-3.0.4_p20190713.tar.xz
+ doc? ( https://github.com/wxWidgets/wxWidgets/releases/download/v${PV}/wxWidgets-${PV}-docs-html.tar.bz2 )"
+S="${WORKDIR}/wxWidgets-${PV}"
+
+LICENSE="wxWinLL-3 GPL-2 doc? ( wxWinFDL-3 )"
+SLOT="${WXRELEASE}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+X doc debug gstreamer libnotify opengl sdl tiff webkit"
+
+RDEPEND="
+ >=app-eselect/eselect-wxwidgets-20131230
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
+ X? (
+ >=dev-libs/glib-2.22:2[${MULTILIB_USEDEP}]
+ media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ virtual/jpeg:0=[${MULTILIB_USEDEP}]
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}]
+ x11-libs/libSM[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]
+ gstreamer? (
+ media-libs/gstreamer:1.0[${MULTILIB_USEDEP}]
+ media-libs/gst-plugins-base:1.0[${MULTILIB_USEDEP}]
+ )
+ libnotify? ( x11-libs/libnotify[${MULTILIB_USEDEP}] )
+ opengl? ( virtual/opengl[${MULTILIB_USEDEP}] )
+ tiff? ( media-libs/tiff:0[${MULTILIB_USEDEP}] )
+ webkit? ( net-libs/webkit-gtk:4 )
+ )"
+DEPEND="${RDEPEND}
+ opengl? ( virtual/glu[${MULTILIB_USEDEP}] )
+ X? ( x11-base/xorg-proto )"
+BDEPEND="
+ >=app-eselect/eselect-wxwidgets-20131230
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${WORKDIR}"/wxGTK-3.0.4_p20190713/
+ "${FILESDIR}"/wxGTK-${SLOT}-translation-domain.patch
+ "${FILESDIR}"/wxGTK-ignore-c++-abi.patch #676878
+)
+
+src_prepare() {
+ default
+
+ # Versionating
+ sed -i \
+ -e "s:\(WX_RELEASE = \).*:\1${WXRELEASE}:"\
+ -e "s:\(WX_RELEASE_NODOT = \).*:\1${WXRELEASE_NODOT}:"\
+ -e "s:\(WX_VERSION = \).*:\1${WXVERSION}:"\
+ -e "s:aclocal):aclocal/wxwin${WXRELEASE_NODOT}.m4):" \
+ -e "s:wxstd.mo:wxstd${WXRELEASE_NODOT}.mo:" \
+ -e "s:wxmsw.mo:wxmsw${WXRELEASE_NODOT}.mo:" \
+ Makefile.in || die
+
+ sed -i \
+ -e "s:\(WX_RELEASE = \).*:\1${WXRELEASE}:"\
+ utils/wxrc/Makefile.in || die
+
+ sed -i \
+ -e "s:\(WX_VERSION=\).*:\1${WXVERSION}:" \
+ -e "s:\(WX_RELEASE=\).*:\1${WXRELEASE}:" \
+ -e "s:\(WX_SUBVERSION=\).*:\1${WXSUBVERSION}:" \
+ -e '/WX_VERSION_TAG=/ s:${WX_RELEASE}:3.0:' \
+ configure || die
+}
+
+multilib_src_configure() {
+ # X independent options
+ local myeconfargs=(
+ --with-zlib=sys
+ --with-expat=sys
+ --enable-compat28
+ $(use_with sdl)
+
+ # Don't hard-code libdir's prefix for wx-config
+ --libdir='${prefix}'/$(get_libdir)
+ )
+
+ # debug in >=2.9
+ # there is no longer separate debug libraries (gtk2ud)
+ # wxDEBUG_LEVEL=1 is the default and we will leave it enabled
+ # wxDEBUG_LEVEL=2 enables assertions that have expensive runtime costs.
+ # apps can disable these features by building w/ -NDEBUG or wxDEBUG_LEVEL_0.
+ # http://docs.wxwidgets.org/3.0/overview_debugging.html
+ # https://groups.google.com/group/wx-dev/browse_thread/thread/c3c7e78d63d7777f/05dee25410052d9c
+ use debug && myeconfargs+=( --enable-debug=max )
+
+ # wxGTK options
+ # --enable-graphics_ctx - needed for webkit, editra
+ # --without-gnomevfs - bug #203389
+ use X && myeconfargs+=(
+ --enable-graphics_ctx
+ --with-gtkprint
+ --enable-gui
+ --with-gtk=3
+ --with-libpng=sys
+ --with-libjpeg=sys
+ --without-gnomevfs
+ $(use_enable gstreamer mediactrl)
+ $(multilib_native_use_enable webkit webview)
+ $(use_with libnotify)
+ $(use_with opengl)
+ $(use_with tiff libtiff sys)
+ )
+
+ # wxBase options
+ ! use X && myeconfargs+=( --disable-gui )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ cd docs || die
+ dodoc changes.txt readme.txt
+ newdoc base/readme.txt base_readme.txt
+ newdoc gtk/readme.txt gtk_readme.txt
+
+ use doc && HTML_DOCS=( "${WORKDIR}"/wxWidgets-${PV}-docs-html/. )
+ einstalldocs
+
+ # Stray windows locale file, bug #650118
+ rm -f "${ED}"/usr/share/locale/it/LC_MESSAGES/wxmsw30-gtk3.mo || die
+
+ # Unversioned links
+ rm "${ED}"/usr/bin/wx{-config,rc} || die
+
+ # version bakefile presets
+ pushd "${ED}"/usr/share/bakefile/presets >/dev/null || die
+ local f
+ for f in wx*; do
+ mv "${f}" "${f/wx/wx30gtk3}" || die
+ done
+ popd >/dev/null || die
+}
+
+pkg_postinst() {
+ has_version -b app-eselect/eselect-wxwidgets \
+ && eselect wxwidgets update
+}
+
+pkg_postrm() {
+ has_version -b app-eselect/eselect-wxwidgets \
+ && eselect wxwidgets update
+}