summaryrefslogtreecommitdiff
path: root/x11-libs/rep-gtk/rep-gtk-0.90.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /x11-libs/rep-gtk/rep-gtk-0.90.8.1.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'x11-libs/rep-gtk/rep-gtk-0.90.8.1.ebuild')
-rw-r--r--x11-libs/rep-gtk/rep-gtk-0.90.8.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-libs/rep-gtk/rep-gtk-0.90.8.1.ebuild b/x11-libs/rep-gtk/rep-gtk-0.90.8.1.ebuild
new file mode 100644
index 000000000000..03812c54a2cd
--- /dev/null
+++ b/x11-libs/rep-gtk/rep-gtk-0.90.8.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit eutils multilib
+
+DESCRIPTION="A GTK+/libglade/GNOME language binding for the librep Lisp environment"
+HOMEPAGE="http://sawfish.wikia.com/wiki/Main_Page"
+SRC_URI="http://download.tuxfamily.org/librep/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="gtk-2.0"
+KEYWORDS="alpha amd64 ia64 ppc ~ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/librep-0.90.5
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.24.0:2
+ >=x11-libs/gdk-pixbuf-2.23:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-arch/xz-utils"
+
+#src_prepare() {
+ # Fix undefined symbol problems like bug #367623
+ # http://listengine.tuxfamily.org/lists.tuxfamily.org/sawfish/2011/09/msg00026.html
+ # TODO: Doesn't apply, if some people still get the failure, try to push a bit upstream
+ #epatch "${FILESDIR}/${PN}-0.90.7-implicit-def-new.patch"
+#}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+ dodoc AUTHORS ChangeLog README* TODO
+}