summaryrefslogtreecommitdiff
path: root/x11-libs/pixman/pixman-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-libs/pixman/pixman-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-libs/pixman/pixman-9999.ebuild')
-rw-r--r--x11-libs/pixman/pixman-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-libs/pixman/pixman-9999.ebuild b/x11-libs/pixman/pixman-9999.ebuild
new file mode 100644
index 000000000000..983516d40153
--- /dev/null
+++ b/x11-libs/pixman/pixman-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+XORG_MULTILIB=yes
+inherit xorg-2
+
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/pixman.git"
+DESCRIPTION="Low-level pixel manipulation routines"
+
+if [[ $PV != 9999* ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+fi
+
+IUSE="altivec iwmmxt loongson2f cpu_flags_x86_mmxext neon cpu_flags_x86_sse2 cpu_flags_x86_ssse3"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable cpu_flags_x86_mmxext mmx)
+ $(use_enable cpu_flags_x86_sse2 sse2)
+ $(use_enable cpu_flags_x86_ssse3 ssse3)
+ $(use_enable altivec vmx)
+ $(use_enable neon arm-neon)
+ $(use_enable iwmmxt arm-iwmmxt)
+ $(use_enable loongson2f loongson-mmi)
+ --disable-gtk
+ --disable-libpng
+ )
+ xorg-2_src_configure
+}