summaryrefslogtreecommitdiff
path: root/x11-libs/libxkbcommon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /x11-libs/libxkbcommon
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest2
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-1.3.1.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index 37f8a9f6bb1f..5cd9ff10b0a2 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,3 +1,5 @@
DIST libxkbcommon-1.3.0.tar.xz 455256 BLAKE2B f53a47005dd411855d1d5c39a33ef58d22982b2d4c2014320722f7fe9a9b468366c6090fadd067e50a846f22de7b80164b684615a8bcb1b14a478609cc4deb74 SHA512 9585ab1df7f2d95b991a786ee1f1de0a645aa315edb93cb093f3409fc76ef7b8f8189a6a7bfd179dc01c5d105d9c9eea40a395762eeffe0618b0c3ee116c0d18
+DIST libxkbcommon-1.3.1.tar.xz 471036 BLAKE2B c46d39876bd4477fe838e17e744ed04388417cfae8bb77c7de48237d31f51fe230d2705733dc0873253b48c61530fbe932e4da7317217c31a7897702fa1d03b4 SHA512 3b2cf6ae9ba4dc8b6fe702ac1fa700034fbc9bd147c73bd2cd93546bcfb71865734b3e46bad35a8fd618ed97266a02dad1dc966c63e6b10404a64919459d933e
EBUILD libxkbcommon-1.3.0.ebuild 1473 BLAKE2B 1899976239bf7e21b0d58228d85f4411a39551b378734b8d5d1d4dbcfb0d56dcc90da3f563c3603b2722f148075da2c0ce7458fc0c18b1ae06301c806ab8e8b2 SHA512 304e75d388e86b30239cb7d846b5cdb7ae5bdaa7b5ea08cffe237eabc159a69d1bb6733612525a0fe0259369f2d40563439f1f2d7712540171554e556885c88a
+EBUILD libxkbcommon-1.3.1.ebuild 1481 BLAKE2B 5a5bb83061a5c4ca5ba9fdc21d892642bf52d07f1161dc2bab145a75839f1e11fbea1bf3055e6bbcadded565889acc10b8526d7a710d5e9279e70c0d5f839be5 SHA512 5c90bae170591b8fc26c0bdb14a055c5bfc93dcfa6a444115574133d32a8befaaef6b146a04a3ed57d3432e301a394ea76429bf622fecdf75c42f67a1097399a
MISC metadata.xml 326 BLAKE2B d18efe3aa2e5fef21aac673bf0c7e951e4e998a9182f1372a343aea035be05252e195d62d991677c90d78dd8ffd89b77c45e4235c3c757e85399c064db7af9e0 SHA512 b6f5d79d6a1243c3bf0511d95748a943545e143242feae120c6932559f003caf3e15de1f56f12f177dba9c00ccbbfb3f8080c7ee95856e401561e67ad0a0a0ea
diff --git a/x11-libs/libxkbcommon/libxkbcommon-1.3.1.ebuild b/x11-libs/libxkbcommon/libxkbcommon-1.3.1.ebuild
new file mode 100644
index 000000000000..afdec5dec587
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-1.3.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit meson-multilib ${GIT_ECLASS} python-any-r1 virtualx
+
+DESCRIPTION="keymap handling library for toolkits and window systems"
+HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
+LICENSE="MIT"
+IUSE="doc static-libs test wayland X"
+RESTRICT="!test? ( test )"
+SLOT="0"
+
+BDEPEND="
+ sys-devel/bison
+ doc? ( app-doc/doxygen )
+ test? ( ${PYTHON_DEPS} )
+ wayland? ( dev-util/wayland-scanner )
+"
+RDEPEND="
+ X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP},xkb] )
+ wayland? ( >=dev-libs/wayland-1.2.0 )
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ wayland? ( >=dev-libs/wayland-protocols-1.12 )
+"
+
+pkg_setup() {
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(meson_use wayland enable-wayland)
+ $(meson_use X enable-x11)
+ $(meson_use doc enable-docs)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx meson_src_test
+}