summaryrefslogtreecommitdiff
path: root/x11-libs/libxkbcommon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-11 05:43:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-11 05:43:34 +0000
commitad391b961414c99124b93cb86695c04bd8d57937 (patch)
tree446151aff1c09db21505a46da4107f9a5be588e0 /x11-libs/libxkbcommon
parent113cc6fe7a9adc2baf67f9ef7723db6ed2b24887 (diff)
gentoo auto-resync : 11:01:2023 - 05:43:34
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest4
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-1.5.0.ebuild69
-rw-r--r--x11-libs/libxkbcommon/metadata.xml2
3 files changed, 73 insertions, 2 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index e80c4870cb76..cccf6ab2d4a7 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,3 +1,5 @@
DIST libxkbcommon-1.4.1.tar.xz 471824 BLAKE2B a784f3612bb52abb79bf1a2ddd3e7709fa52eddce5cabcf8520ed7df8ec8ea557e51205e1e9d116a0b31eb27b1f3bca33144318c5f01be7312cbb3e48f687fbe SHA512 757b340aeab6d187917807a88015b5113475ab2172aaaa8e530b40ea60619b3fbdfa668fd62707d66ed8fb763e68fee19394fcbd519af7c01d8975c59fdf0d89
+DIST libxkbcommon-1.5.0.tar.xz 472700 BLAKE2B 5dcfb514c297f71629f20b444cb29c5d26ce9def1c1173a125fb0c0c259d76194fcef7a407d8efda2d2d87c9b90abac34e2fc1742cfd6053df511a3ef205c8ef SHA512 bbba6665f052c04c7450413cc5e2badd6bfd41326b0e4c60e3ec01d730cae695fd34ce2662b8a91ece7a76b974a0ea330f7462dd5d2db148b0d0da26264ced9c
EBUILD libxkbcommon-1.4.1.ebuild 1545 BLAKE2B 7b0af3e3b664290fc834f621ccc0c740bdfb31c4e342380fc9847857f8172c4d68b486822547fcee5bf37cc13d4faaf460a9a9930a546d33f4c54266bea5dcba SHA512 ffc63c15e96bcef0ba4c7a28b12ffff1e7a72888f467a9b6f3ee5466330dd7bc98473fedbf0e271b1dd0da48fe829177ec56a3a4b5314ed20bdb3fef5e3f3a4c
-MISC metadata.xml 482 BLAKE2B ab0da50f2f6fa4c4afd8b242e2015b75e5dc101e8846a587768f46041350b54bc8af9d1e8ac7651739d1d6c86b4dc57d4b5f29837f1b48eec433fe9b13c64ff3 SHA512 17d555622c7535d581db415d696e75f440bd4360beef21cb2e2852eb9ab700fd20d3a23a2fbfcd052b64167086adf6f69beacbab96f080d626c10f28d268d968
+EBUILD libxkbcommon-1.5.0.ebuild 1696 BLAKE2B 8008a0fe0f839097e01c6c260bd528ff496273cefce89ff2de956fd4196302e54ee17854e9734991d00aaa5e7de0a255934e63b64507dd1b555be77aec68162a SHA512 cf55badaacebf9eb03a31186dbf85943bb9d31360db696da09e604c74444eb4a0a61835a44bd991840457613c8c740323f7a4273d14ce8b83d56d5b76bd37cff
+MISC metadata.xml 470 BLAKE2B 4edc4923d3888c12474fb659cf1fb1177c600fba9e8fd34fd6be284c979313bb3282d0fa9084c0aee29d9413e68947dd0ee2d241af4e78b2eb06887d2d684f6b SHA512 e19a6e154a79578d5641dfdbef8e963794b14ef0b0f63450dba2d24044e83b517991a72d81598420567978dcecb9d4e4f0eb9e4cf63e0b562d3e41aa80b39a87
diff --git a/x11-libs/libxkbcommon/libxkbcommon-1.5.0.ebuild b/x11-libs/libxkbcommon/libxkbcommon-1.5.0.ebuild
new file mode 100644
index 000000000000..3d39d2917fd0
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-1.5.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit meson-multilib ${GIT_ECLASS} python-any-r1 virtualx
+
+DESCRIPTION="keymap handling library for toolkits and window systems"
+HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
+LICENSE="MIT"
+IUSE="doc static-libs test tools wayland X"
+RESTRICT="!test? ( test )"
+SLOT="0"
+
+BDEPEND="
+ sys-devel/bison
+ doc? ( app-doc/doxygen )
+ test? ( ${PYTHON_DEPS} )
+ wayland? ( dev-util/wayland-scanner )
+"
+RDEPEND="
+ X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1.2.0[${MULTILIB_USEDEP}] )
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables
+ x11-misc/xkeyboard-config
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ wayland? ( >=dev-libs/wayland-protocols-1.12 )
+"
+
+pkg_setup() {
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(meson_native_use_bool tools enable-tools)
+ $(meson_use X enable-x11)
+ $(meson_native_use_bool doc enable-docs)
+ $(meson_use wayland enable-wayland)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx meson_src_test
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ mv "${ED}"/usr/share/doc/{${PN},${P}} || die
+ fi
+}
diff --git a/x11-libs/libxkbcommon/metadata.xml b/x11-libs/libxkbcommon/metadata.xml
index 887150f5375a..9f2f9f386d67 100644
--- a/x11-libs/libxkbcommon/metadata.xml
+++ b/x11-libs/libxkbcommon/metadata.xml
@@ -10,6 +10,6 @@
</use>
<upstream>
<remote-id type="cpe">cpe:/a:xkbcommon:libxkbcommon</remote-id>
- <remote-id type="freedesktop-gitlab">xkbcommon/libxkbcommon</remote-id>
+ <remote-id type="github">xkbcommon/libxkbcommon</remote-id>
</upstream>
</pkgmetadata>