summaryrefslogtreecommitdiff
path: root/x11-libs/libxkbcommon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-26 19:01:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-26 19:01:21 +0000
commit82fd88ea93e273f4b02580552f808b6305d1e840 (patch)
treeda485ff18e7c82cfdd34040e8c5c8a2712d565fe /x11-libs/libxkbcommon
parente978c365080e8765f234868ad266cd333c53a94f (diff)
gentoo auto-resync : 26:03:2024 - 19:01:20
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest2
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-1.7.0.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index bfb040bcddb9..d0d17b2f727d 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,3 +1,5 @@
DIST libxkbcommon-1.6.0.tar.xz 510456 BLAKE2B ffd373161f12ea6448a9206f57710355ab65b81ebab5dce74e4dfcee1bdc9175406fc434560648f5933b83cac163099c8564c3add6f51d34856def39ab077850 SHA512 4f93225eada1c5d0806bbc01f72d82d72729f4580ade963ff6a386711c9b2232aae5213c8488abf01c3b81f0e1fdb7f4d8a4d3786113ccc134251ff164c4be5c
+DIST libxkbcommon-1.7.0.tar.xz 534312 BLAKE2B b85cd8a78fce3c624e0c64c26a37b6d99bb8b8f3de489c6909826f53bdb6d33842f7ffcf955f6a9a8eb57cad53fc9756bd15d05aeb813b0f92985827243949a8 SHA512 4b74a9f3f63e2ebc1cbdcaa963c70362e55fa527e1d89b6a1fd30d7a84a8b60c1b3dc99bcfbde85aa31890e0b2f62f0bad3c8ff8340fe6a930ee662b33448ba5
EBUILD libxkbcommon-1.6.0.ebuild 1800 BLAKE2B 3ff0a87b69159bba55da65e28e11baf189626ebf6f618d231d5ff75fb9f0a38ef8a5d44b3d8cffba2494df89b62a285ec8f7bdd743bc0ef25c1ed6e5379257d3 SHA512 310a38ffa4ce0c92fcf827e76a17520952fa7fb0c80c496a1e25d6e3237ea8e9a057faa181827b461a05d18c8bedc8bcaa343cd615720eb153a269f53d56f668
+EBUILD libxkbcommon-1.7.0.ebuild 1808 BLAKE2B 0f77db25b459d8073d144d4eb5f5d734e204cda544568fe75cdd651426230dbf769a17c42feeb49db32e6ca7e8e329bb210e736ef669a1286ad6c00196224cac SHA512 db529d2a1aaf17921ef106710150d927ac5afe0979c9f966b219ecf7f2ce061789e019e60a97992e5db73884b3562370f8c2d436decf6b7036ef858603376275
MISC metadata.xml 470 BLAKE2B 4edc4923d3888c12474fb659cf1fb1177c600fba9e8fd34fd6be284c979313bb3282d0fa9084c0aee29d9413e68947dd0ee2d241af4e78b2eb06887d2d684f6b SHA512 e19a6e154a79578d5641dfdbef8e963794b14ef0b0f63450dba2d24044e83b517991a72d81598420567978dcecb9d4e4f0eb9e4cf63e0b562d3e41aa80b39a87
diff --git a/x11-libs/libxkbcommon/libxkbcommon-1.7.0.ebuild b/x11-libs/libxkbcommon/libxkbcommon-1.7.0.ebuild
new file mode 100644
index 000000000000..32c1fc5823e6
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-1.7.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 meson-multilib ${GIT_ECLASS} python-any-r1 virtualx
+
+DESCRIPTION="Keymap handling library for toolkits and window systems"
+HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="doc static-libs test tools wayland X"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-alternatives/yacc
+ doc? ( app-text/doxygen[dot] )
+ test? ( ${PYTHON_DEPS} )
+ tools? ( wayland? ( dev-util/wayland-scanner ) )
+"
+RDEPEND="
+ X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP}] )
+ tools? ( wayland? ( >=dev-libs/wayland-1.2.0[${MULTILIB_USEDEP}] ) )
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables
+ x11-misc/xkeyboard-config
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ tools? ( wayland? ( >=dev-libs/wayland-protocols-1.12 ) )
+"
+
+pkg_setup() {
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ -Dbash-completion-path="$(get_bashcompdir)"
+ $(meson_native_use_bool tools enable-tools)
+ $(meson_use X enable-x11)
+ $(meson_native_use_bool doc enable-docs)
+ $(meson_use wayland enable-wayland)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx meson_src_test
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ mv "${ED}"/usr/share/doc/{${PN},${P}} || die
+ fi
+}