summaryrefslogtreecommitdiff
path: root/x11-libs/libxkbcommon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /x11-libs/libxkbcommon
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest2
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-0.8.3.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index f6e957c3a8bb..e652d4657d97 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,3 +1,5 @@
DIST libxkbcommon-0.8.2.tar.xz 644040 BLAKE2B c323384308d9730924d6f1cb7ad55fdb3d1a37289f648b981c54dc5997c67c857d33f8ad872fc7646b462ebc97252dca30efe2a2e12d1f1f08a8a1604a5de23f SHA512 b714240ec6120bbe44b5da7a4f89b1c2f24cfd6e5ebbe81e5290d135c8f2e5a68f89ac256b73430a446167345f8db309b35dcf74f3d3840e20897cd91eccc172
+DIST libxkbcommon-0.8.3.tar.xz 646124 BLAKE2B c80d5065395ee8adec436243cf42fa82a05a5797be711b4e10d70d92ef742c707f034adf870480e1797e1b05135b5ce644e6ebefd036aaac7d3fb7435b5bd543 SHA512 0a3dfacc17eddfc10fe3edb946bede5070f2744effe642bd96076996f262a41addb691d62c0d738457da522d1fea02c297c9a2a8b1f56521adbf50ca917577c2
EBUILD libxkbcommon-0.8.2.ebuild 928 BLAKE2B 08e1d3188c38bc14a9ba866d530e1768a2b8f4b13d1ad7eed9e342d54049e7e4f2c3e39d666b9ecc95e4f325720cb66ada4ce7d485a46dddb5e8c6937d4e75de SHA512 6717271f5b12543c3a47bc53c2d181bef7e2552c5234de51c693dadfda3f6287e41755674720e9fb31df3002fa8357f74e711c4637be195b8626b62ff3121f71
+EBUILD libxkbcommon-0.8.3.ebuild 939 BLAKE2B a9d45b076253fa3757162f9652ef043404b08c94177326e77bc0a6d36da69e07916be6b04ee9f81a8025358f4760bfdc90abdfa92650273f3f4c2a3d074ef670 SHA512 d380a6b36bedca1f265b75ca9a51ae665daff47d6e8b2555b80d74bea490e040eb947e0f9c25b030631cc849306684c4112c9dca95a9dcea51200e70e36f23d9
MISC metadata.xml 234 BLAKE2B b45f6795dbd73dfcee2a68f93ec5460509b15a69401467bc8f4af9505eeb04a2aa35a2b144eb88781df4abd4e15d2b88fc728daf033c6d646762170ffb00b1a7 SHA512 fabcd59aeede4ac93d66552746edacc44fd565551aafaca67185aff7f8e6a4c0fa21f3d54e4fccd7def948ec57b90489631bd779fb992cd9322132b0a3aa503b
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.8.3.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.8.3.ebuild
new file mode 100644
index 000000000000..20521c37215d
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-0.8.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+XORG_MULTILIB="yes"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ XORG_BASE_INDIVIDUAL_URI=""
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+fi
+
+inherit xorg-2 ${GIT_ECLASS}
+
+DESCRIPTION="X.Org xkbcommon library"
+HOMEPAGE="https://xkbcommon.org/"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
+IUSE="X doc test"
+
+DEPEND="sys-devel/bison
+ X? (
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb]
+ )
+ doc? ( app-doc/doxygen )"
+RDEPEND="X? ( >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb] )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(use X || use_enable X x11)
+ $(use_with doc doxygen)
+ )
+ xorg-2_pkg_setup
+}