summaryrefslogtreecommitdiff
path: root/x11-libs/libxkbcommon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /x11-libs/libxkbcommon
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest2
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-1.2.1.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index 4766cb7caeef..50bf1a945936 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,5 +1,7 @@
DIST libxkbcommon-1.0.3.tar.xz 432944 BLAKE2B 49dcefcc17cbbfe5623728e9852e700a623e07ad7e6df78c8d7c39784948eb230f9e141d8aaa1de94305cb552244fe54d384abbc8e57f5ec5846915b5ae484e3 SHA512 b05a2db0acd6628427baad1967979a161019dec90a078a926d41f4dfeffb84eab63e627803df1a401e42c8e48953d6c434ce08d7206eae21e890890f29b03d3c
DIST libxkbcommon-1.1.0.tar.xz 439488 BLAKE2B ddccb9942af5f5d80b750bf8f02289e073615c99bed2a8f7ff1d03ca70bffdbe3b1fe15daef2346819887efe10a308d00f671fc2ae50e0fe33e76e4b748f6d01 SHA512 6137329653ada711abc0e093532627111ab1fb53e6b2b0d05ec4d77709cfc4368f094ebbf68b23c8e9af9a69826351b64466e81c11e6593eafa7e43cd3e7bf75
+DIST libxkbcommon-1.2.1.tar.xz 453172 BLAKE2B f8846befae348287032601f589607a9c899826135b325245824650d77435050fe7e300514cc9f16bd0f3c37693c9f8f08d78aa738c160676019338d72addcd80 SHA512 28de91166a289586a78068b725b904da46fca144936ea0677ec9234c7f0499b9ae321d79c57f15782b63c6e7a37b074fe44648673a2294bbde13110195567e3b
EBUILD libxkbcommon-1.0.3.ebuild 1432 BLAKE2B 5514381f7eb6cc03053fb2544516395fc6c67a59d7e1c6fe7348167c6ebc719428aa28e6e5b37181fdb49cdf4f36167df8847f41ddc484f2c76a9f44eb0ffbd8 SHA512 44dd4acfa62d35cf1a0a8f0cf39c56872c4c589ef6a0c67d7b4e7bc09e0c77241f6cd8bf68632c864993feddc3fa72d5be7096992316956f115609795a3f8eca
EBUILD libxkbcommon-1.1.0.ebuild 1484 BLAKE2B 1f2dc69b9799e90f1c0e10e1aea913badb6f9ed56eac8b1b2607992c89b8286d222344a6d96b4904523bf1325e1747c274ef5ae9edebb237ecca54eb29de68dd SHA512 50619d539aed08f4f3fa84b573814d3b51f79ed07b8cde27a85b31c00e5c738107d2bea6d2b1d5d53bfacadd090e3d69c78304dc78de07663e2a6bfb746d25d4
+EBUILD libxkbcommon-1.2.1.ebuild 1439 BLAKE2B 0e39989ff26c13f2c25501cde2b99df369ab325d9ee5a9a06a284f327d932f1f625d5cc9fed3662e5bb493a08579e3f36ca6f161728dd663f7c95dca510f921c SHA512 6eae5aafbbb1e12b193929ed6170647b1682ffd88e27a3d596c391db31b46f1a13e2a530c9580a4e227b3ba43122e18035d7fb5a7b5c0e94fcf9a0454516f3b4
MISC metadata.xml 325 BLAKE2B db764fac0ca1f4359bcd129dc165f78592535dee40bc25b6f2d7c662bdce43e01cc66b362765607665a75fc5b1703de204cf90eecae4f8d285cfaefcebc614b8 SHA512 ca2a116a574783f7b3c6191759c902e2cb059ec135456cef989b81be07fecc48f9ff56e02845d18c2376c99be3dd9711f39ad91394e421fa36d8fd6453c0a121
diff --git a/x11-libs/libxkbcommon/libxkbcommon-1.2.1.ebuild b/x11-libs/libxkbcommon/libxkbcommon-1.2.1.ebuild
new file mode 100644
index 000000000000..c34ea6d0be18
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-1.2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit meson multilib-minimal ${GIT_ECLASS} python-any-r1
+
+DESCRIPTION="keymap handling library for toolkits and window systems"
+HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
+LICENSE="MIT"
+IUSE="X doc static-libs test"
+RESTRICT="!test? ( test )"
+SLOT="0"
+
+BDEPEND="
+ sys-devel/bison
+ doc? ( app-doc/doxygen )
+ test? ( ${PYTHON_DEPS} )
+"
+RDEPEND="
+ X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP},xkb] )
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+
+pkg_setup() {
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ -Denable-wayland=false # Demo applications
+ $(meson_use X enable-x11)
+ $(meson_use doc enable-docs)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}