summaryrefslogtreecommitdiff
path: root/x11-libs/libxkbcommon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-12 06:32:46 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-12 06:32:46 +0100
commit28e3d252dc8ac8a5635206dfefe1cfe05058d1db (patch)
treee75bce604750fb72e53ed3684059e2e5d2094509 /x11-libs/libxkbcommon
parentf625b9919a60a30f1bd860f7d1b2eac183ced593 (diff)
gentoo resync : 12.08.2018
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest2
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-0.8.2.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index ec9d275a2cf9..316d32bf87d1 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,3 +1,5 @@
DIST libxkbcommon-0.8.0.tar.xz 643456 BLAKE2B 37f8e8ccff63354dc37ec26091a7da28f5a1f05ca0656b03716cdcdbf3172344d600b3b2b646da309ea3e4f04bde1b1279c96b07c493266ec6489935177efbbc SHA512 ad64baa03685b72e1047f9fdfc95661acf5bace59280a95d3defaca73c91fb77c31ecde00b430726e3521ff90cf8dd93ecbc816c18be0971cb616e00b81cf163
+DIST libxkbcommon-0.8.2.tar.xz 644040 BLAKE2B c323384308d9730924d6f1cb7ad55fdb3d1a37289f648b981c54dc5997c67c857d33f8ad872fc7646b462ebc97252dca30efe2a2e12d1f1f08a8a1604a5de23f SHA512 b714240ec6120bbe44b5da7a4f89b1c2f24cfd6e5ebbe81e5290d135c8f2e5a68f89ac256b73430a446167345f8db309b35dcf74f3d3840e20897cd91eccc172
EBUILD libxkbcommon-0.8.0.ebuild 932 BLAKE2B 98608f210178be94f2406156ee8d67c684d701b5d75d447654dde06f364df6eb74e938516f01141b737ec8897c5a3cec358cd7b18729bcf5b66a75b0369598be SHA512 4f50217c180e8a09a34fa89ce939136f8ef59b6989ba07390b8568f74736ed017754759b7f7e2a7f08dd61191713565e6dff9dcd6b1a5a25e4fa29e7f04ca8ea
+EBUILD libxkbcommon-0.8.2.ebuild 942 BLAKE2B a00d5482005591327815bbef6b4510e724de5b95e8746d3268fdb9f4ea75292e3a65f0676d14e3739ae86bd67b078ec76d2164bbbae62ceddc7700ed97ad433f SHA512 c186425cd38ecd4cc8a85d6687df4014f8885f8c406fc9d7d6a8b68085dc6c9cc3cb24641ff3df773271a361447841daa4ebc5eb8f44e23e451f6ac744f322fb
MISC metadata.xml 234 BLAKE2B b45f6795dbd73dfcee2a68f93ec5460509b15a69401467bc8f4af9505eeb04a2aa35a2b144eb88781df4abd4e15d2b88fc728daf033c6d646762170ffb00b1a7 SHA512 fabcd59aeede4ac93d66552746edacc44fd565551aafaca67185aff7f8e6a4c0fa21f3d54e4fccd7def948ec57b90489631bd779fb992cd9322132b0a3aa503b
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.8.2.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.8.2.ebuild
new file mode 100644
index 000000000000..ceb492d0aaff
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-0.8.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+XORG_MULTILIB="yes"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ XORG_BASE_INDIVIDUAL_URI=""
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+fi
+
+inherit xorg-2 ${GIT_ECLASS}
+
+DESCRIPTION="X.Org xkbcommon library"
+HOMEPAGE="https://xkbcommon.org/"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
+IUSE="X doc test"
+
+DEPEND="sys-devel/bison
+ X? (
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb]
+ )
+ doc? ( app-doc/doxygen )"
+RDEPEND="X? ( >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb] )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(use X || use_enable X x11)
+ $(use_with doc doxygen)
+ )
+ xorg-2_pkg_setup
+}