summaryrefslogtreecommitdiff
path: root/x11-libs/libxkbcommon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-11 00:12:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-11 00:12:38 +0000
commit0ec1e1dd7867c3dedcbea76c9b6e847d6b388c03 (patch)
tree65f42b72245de9fb9fa9ea30e6221dfff7dda7c5 /x11-libs/libxkbcommon
parent3a81cede4783e464b7485722b2eaac0280dbc570 (diff)
gentoo auto-resync : 11:02:2025 - 00:12:37
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest2
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-1.8.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index 5f1697957b1b..8b8907045350 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,4 +1,6 @@
AUX libxkbcommon-1.7.0-symbol-ver.patch 3905 BLAKE2B 4dd577bf14806a854009dd6065841be6c4ccb900336aab79b4d41e164e9e85ac00c513a644f30a1aaf60c1de84780e8ffd356c3325b20e2ec5890bbfa0145999 SHA512 7acb5488683bd0d27b7decafbd9231b30ebf5dc6e089a48873dffac6be16290fc7ea6409f0539eac1cc35a17df88c0fde3cb91fcf7d337366ab785ef1f6013dd
DIST libxkbcommon-1.7.0.tar.xz 534312 BLAKE2B b85cd8a78fce3c624e0c64c26a37b6d99bb8b8f3de489c6909826f53bdb6d33842f7ffcf955f6a9a8eb57cad53fc9756bd15d05aeb813b0f92985827243949a8 SHA512 4b74a9f3f63e2ebc1cbdcaa963c70362e55fa527e1d89b6a1fd30d7a84a8b60c1b3dc99bcfbde85aa31890e0b2f62f0bad3c8ff8340fe6a930ee662b33448ba5
+DIST libxkbcommon-1.8.0.tar.gz 995648 BLAKE2B 8edd795aff35c881bfad7905b4dc73d4a99fde23afad1b8874cb599490b5245e6b1d83a97dfd7a2031c1d232618c9a8ecfd586990b4a46df1eb87944f20660c1 SHA512 2e9a9c02bcc515c43db38266ad4b23d3530be3de28d05e086d3c12155cf1c569609a55fa4ea4ca9b0adbd8d2a553724bfa78f63481487bfee6379b3664f3aed0
EBUILD libxkbcommon-1.7.0-r1.ebuild 1858 BLAKE2B 57742992bbf495c4aa210f861d432dd0bb2354974757315db8657273493d74918034a734daea576718f66ffdc27616e6976904604b1ba5b8b9e2eaaf6819ab3e SHA512 41b958ab457caa13e4fea060cac0e9fe8c6fbffe6197af6b1a1c7746dc403dd90bdf58a6c53d7255986fa96ceae0bbf5e1683679e4ee9bdec0f685f3dd2a03ab
+EBUILD libxkbcommon-1.8.0.ebuild 1902 BLAKE2B f482dce10215e5a8a5d7493b4ef8c2a186af4654a23750e85450d4b4a7507e947260f2f963980376681329068e9127c788873dfe43b1a7afbcb85d61b3dab64a SHA512 ad20aa84596c1b453ea77903d1e9bdd3efc0ece99816595bae49d2826c278fc7692f02df930e6f37b0b05fba67c9ecbb02321f81c3a5bebbb7c0c0f8c09c675f
MISC metadata.xml 470 BLAKE2B 4edc4923d3888c12474fb659cf1fb1177c600fba9e8fd34fd6be284c979313bb3282d0fa9084c0aee29d9413e68947dd0ee2d241af4e78b2eb06887d2d684f6b SHA512 e19a6e154a79578d5641dfdbef8e963794b14ef0b0f63450dba2d24044e83b517991a72d81598420567978dcecb9d4e4f0eb9e4cf63e0b562d3e41aa80b39a87
diff --git a/x11-libs/libxkbcommon/libxkbcommon-1.8.0.ebuild b/x11-libs/libxkbcommon/libxkbcommon-1.8.0.ebuild
new file mode 100644
index 000000000000..4c16b4dcbd79
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-1.8.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ SRC_URI="https://github.com/xkbcommon/libxkbcommon/archive/refs/tags/xkbcommon-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ S="${WORKDIR}/libxkbcommon-xkbcommon-${PV}"
+fi
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 meson-multilib ${GIT_ECLASS} python-any-r1 virtualx
+
+DESCRIPTION="Keymap handling library for toolkits and window systems"
+HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="doc static-libs test tools wayland X"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ app-alternatives/yacc
+ doc? ( app-text/doxygen[dot] )
+ test? ( ${PYTHON_DEPS} )
+ tools? ( wayland? ( dev-util/wayland-scanner ) )
+"
+RDEPEND="
+ X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP}] )
+ tools? ( wayland? ( >=dev-libs/wayland-1.2.0[${MULTILIB_USEDEP}] ) )
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables
+ x11-misc/xkeyboard-config
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ tools? ( wayland? ( >=dev-libs/wayland-protocols-1.12 ) )
+"
+
+pkg_setup() {
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ -Dbash-completion-path="$(get_bashcompdir)"
+ $(meson_native_use_bool tools enable-tools)
+ $(meson_use X enable-x11)
+ $(meson_native_use_bool doc enable-docs)
+ $(meson_use wayland enable-wayland)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx meson_src_test
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ mv "${ED}"/usr/share/doc/{${PN},${P}} || die
+ fi
+}