summaryrefslogtreecommitdiff
path: root/x11-libs/libxkbcommon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-10 00:07:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-10 00:07:53 +0100
commit024d1b6f101ade7073320fba887d4808c933a8e8 (patch)
tree421168a6409273df1171f750816ce32dc2779a4f /x11-libs/libxkbcommon
parent4e4ee9865a958b6a854f9bca96637244c628d525 (diff)
gentoo auto-resync : 10:10:2023 - 00:07:53
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest2
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-1.6.0.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index f104425b37d8..c4b8546adf12 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,3 +1,5 @@
DIST libxkbcommon-1.5.0.tar.xz 472700 BLAKE2B 5dcfb514c297f71629f20b444cb29c5d26ce9def1c1173a125fb0c0c259d76194fcef7a407d8efda2d2d87c9b90abac34e2fc1742cfd6053df511a3ef205c8ef SHA512 bbba6665f052c04c7450413cc5e2badd6bfd41326b0e4c60e3ec01d730cae695fd34ce2662b8a91ece7a76b974a0ea330f7462dd5d2db148b0d0da26264ced9c
+DIST libxkbcommon-1.6.0.tar.xz 510456 BLAKE2B ffd373161f12ea6448a9206f57710355ab65b81ebab5dce74e4dfcee1bdc9175406fc434560648f5933b83cac163099c8564c3add6f51d34856def39ab077850 SHA512 4f93225eada1c5d0806bbc01f72d82d72729f4580ade963ff6a386711c9b2232aae5213c8488abf01c3b81f0e1fdb7f4d8a4d3786113ccc134251ff164c4be5c
EBUILD libxkbcommon-1.5.0.ebuild 1689 BLAKE2B be1dc727a392d7237ec09380ce2e799cb07abcae3a771460144ca94dd5f5ff753dd23e5550fa1c0a03eeb78c171d3534d5e5f24558e4583ec2a66d2e525f4fdc SHA512 34951734cd4ada20070c688b89fd9f78855fa8d0e104c6302399d6749a1194cd0fe0f3e63fbba4c1125771c3d94edd1184598184995b21e7cb2aae772a1764fa
+EBUILD libxkbcommon-1.6.0.ebuild 1795 BLAKE2B 3ae056ade969b74819f16598f1cd9484f649e46ceeb705818134e15923648e08566f0851e19fa3139947ffc684aa2ab2d24cc21f7850a8c51f9daffcfdf584fc SHA512 07caee6490f6f146044c80f0026b241e923be433277908a58b916469c7ff003f4b218d4f23534ae28a647528ed60e65464f733f7d002765895b8765ec65c90e3
MISC metadata.xml 470 BLAKE2B 4edc4923d3888c12474fb659cf1fb1177c600fba9e8fd34fd6be284c979313bb3282d0fa9084c0aee29d9413e68947dd0ee2d241af4e78b2eb06887d2d684f6b SHA512 e19a6e154a79578d5641dfdbef8e963794b14ef0b0f63450dba2d24044e83b517991a72d81598420567978dcecb9d4e4f0eb9e4cf63e0b562d3e41aa80b39a87
diff --git a/x11-libs/libxkbcommon/libxkbcommon-1.6.0.ebuild b/x11-libs/libxkbcommon/libxkbcommon-1.6.0.ebuild
new file mode 100644
index 000000000000..edf3040dd26b
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-1.6.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 meson-multilib ${GIT_ECLASS} python-any-r1 virtualx
+
+DESCRIPTION="Keymap handling library for toolkits and window systems"
+HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
+LICENSE="MIT"
+IUSE="doc static-libs test tools wayland X"
+RESTRICT="!test? ( test )"
+SLOT="0"
+
+BDEPEND="
+ sys-devel/bison
+ doc? ( app-doc/doxygen )
+ test? ( ${PYTHON_DEPS} )
+ tools? ( wayland? ( dev-util/wayland-scanner ) )
+"
+RDEPEND="
+ X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP}] )
+ tools? ( wayland? ( >=dev-libs/wayland-1.2.0[${MULTILIB_USEDEP}] ) )
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables
+ x11-misc/xkeyboard-config
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ tools? ( wayland? ( >=dev-libs/wayland-protocols-1.12 ) )
+"
+
+pkg_setup() {
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ -Dbash-completion-path="$(get_bashcompdir)"
+ $(meson_native_use_bool tools enable-tools)
+ $(meson_use X enable-x11)
+ $(meson_native_use_bool doc enable-docs)
+ $(meson_use wayland enable-wayland)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx meson_src_test
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ mv "${ED}"/usr/share/doc/{${PN},${P}} || die
+ fi
+}