summaryrefslogtreecommitdiff
path: root/x11-libs/libxcb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /x11-libs/libxcb
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'x11-libs/libxcb')
-rw-r--r--x11-libs/libxcb/Manifest2
-rw-r--r--x11-libs/libxcb/libxcb-1.15.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/x11-libs/libxcb/Manifest b/x11-libs/libxcb/Manifest
index 44d9c1a54348..cbb428bd159c 100644
--- a/x11-libs/libxcb/Manifest
+++ b/x11-libs/libxcb/Manifest
@@ -1,4 +1,6 @@
AUX libxcb-1.14-tests-don-t-use-deprecated-fail_unless-check-API.patch 5795 BLAKE2B 0a864b0fbd998fdc6c151b9f9cdb2a31797ac693b4ffa164a6f9a3c0fc1c5430454ec97be4c52ed48489cb08e820a998086fc588cdd2348b16da122bd483b8bc SHA512 e5148c7c310ca395b7e0f3b76ef98d79e50d0ac58935ad6df3c71bfd426166ce736ccfff4970e9523a2418820cd7cb2cba6e8818f23dd5cc21dac69accc1c3f9
DIST libxcb-1.14.tar.xz 439404 BLAKE2B 63605e02dd32b4d26b3ac6d3b93b7383dbc30701b9a063e8efa5b387215c9325196451f80c7b0b357df1773c6fd1224eea8eeca2a456055a2cdc61082c726111 SHA512 b90a23204b0d2c29d8b115577edb01df0465e02d6a8876550fecd62375d24a5d5f872ddd5946772ddba077cadce75b12c7a6d218469dc30b5b92bc82188e8bc6
+DIST libxcb-1.15.tar.xz 446492 BLAKE2B d50146ee9b822dfd0c24513110e1706cda05ce588f276005167a911d3097275f36be1ce755c42c2b2970e750f10b2b943f3e373b6e55865fba986e29811a3545 SHA512 f6c7d766b7cf9cab6abe948ee424cbae6951dbfe2f76fa58a109cdc05b0f0919dcc4e38176a22ff4b95fc1e38596115317e32ba33b24cae0035a4e30dbcbdad9
EBUILD libxcb-1.14.ebuild 1500 BLAKE2B 31d68d2b246e4da3906e3a1507fa83a151a9ee3b66427192dc1917d95fe3e48c43765b8284d8f074d2f8a19c82e2f1055f36aac4c515f0096339547ce753e57c SHA512 6e86fde7e6b6c011b81b946a6a1f22070285d75e8001dd9a31e059e9579287b2c863425c505dac0de14ccf613541b660d06e771313d4b639ba2d2db8b91e1ed1
+EBUILD libxcb-1.15.ebuild 1427 BLAKE2B 2f951f68b04f71599829c502b240cb6a028f9ee62d521b7254ffe203a91ab39918783f8b335b2a829813bb92e7ee009b414d0387d480c1d2fe312e7d328508ea SHA512 8723fe98d3a9ca995e587deeb1c49c44b78febfddb1ee81cd543ece1786dcd3e6f18f9a00118d5b6c38317d5ae95f69e460f1333da9f9121b71510b551b0aee1
MISC metadata.xml 401 BLAKE2B 67d85ae2c4ac6eecb10245666173d96f896ec9eddc36c8d0890092cbd19c7dd685f327332235937afbb119fa6e69860920fc1e385fdc750d89c85b67a9fbaa20 SHA512 72981a4b87a9219573847178c3d50f9a182c0b0a82917d3d472be062a5bb5e21422bc1776a8988b0ff0a5248a6f5eabe3dee3aa51612b31a7da283fd870b58ab
diff --git a/x11-libs/libxcb/libxcb-1.15.ebuild b/x11-libs/libxcb/libxcb-1.15.ebuild
new file mode 100644
index 000000000000..38cd08cb34f8
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.15.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE=xml
+
+XORG_TARBALL_SUFFIX="xz"
+XORG_MULTILIB=yes
+XORG_DOC=doc
+
+inherit python-any-r1 xorg-3
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc selinux test +xkb"
+RESTRICT="!test? ( test )"
+SLOT="0/1.12"
+
+RDEPEND="
+ >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXdmcp-1.1.1-r1[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=x11-base/xcb-proto-1.15[${MULTILIB_USEDEP}]
+ elibc_Darwin? ( dev-libs/libpthread-stubs )
+ test? ( dev-libs/check[${MULTILIB_USEDEP}] )
+"
+# Note: ${PYTHON_USEDEP} needs to go verbatim
+BDEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep '>=x11-base/xcb-proto-1.15[${PYTHON_USEDEP}]')
+ doc? ( app-doc/doxygen[dot] )
+ test? ( dev-libs/libxslt )
+"
+
+python_check_deps() {
+ has_version -b ">=x11-base/xcb-proto-1.15[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ xorg-3_pkg_setup
+}
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc devel-docs)
+ $(use_enable selinux)
+ )
+ xorg-3_src_configure
+}