summaryrefslogtreecommitdiff
path: root/x11-libs/libva
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /x11-libs/libva
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'x11-libs/libva')
-rw-r--r--x11-libs/libva/Manifest3
-rw-r--r--x11-libs/libva/libva-2.13.0-r2.ebuild87
-rw-r--r--x11-libs/libva/libva-9999.ebuild2
3 files changed, 90 insertions, 2 deletions
diff --git a/x11-libs/libva/Manifest b/x11-libs/libva/Manifest
index 5651e25f326c..7e4d8f257228 100644
--- a/x11-libs/libva/Manifest
+++ b/x11-libs/libva/Manifest
@@ -1,4 +1,5 @@
DIST libva-2.13.0.tar.gz 256724 BLAKE2B 97dd51bf488dc88027125973399e17dedcce03b7bf5104fd9bf17156c5013e1e9d46f2bf78c16431141294f75549a00fed3542b4f79dd31b032f4505c11d07d7 SHA512 226d09956754c9942348ed289f210268bad64dbba95d948b33ae063f7ecb276af9da083a48c03c3c79ad4305716d203898bc75a109945d064a5fe6fb43398dea
EBUILD libva-2.13.0-r1.ebuild 2219 BLAKE2B edefe41042978eb61e2d0f75c2c4befab859ddc267a3b9a5719eaaefb38a3c88f58b3bb09f1c69345acb6df72858add5ac443ca076d0f8262daa3ca17469aa39 SHA512 afb649de60b6760ab1a2ff67b2d88c5cf0b09bfa5405258268e91aa987324dbf005e36f76236cb2ae441c2d7b693f6e949585026a2296c67a809927285d80f24
-EBUILD libva-9999.ebuild 2223 BLAKE2B 2401aa2c500de6a88750f33a4e964c3113a4a782ff4a9e50e6f41b6434e6e397b9d86da12ed424c928535f9c9b75e2f4823413a6c70b28358d7ad538c9b529c7 SHA512 693a23ecfbbb04769e8ae58ac62b1c5e95fc415b478889c63cdacf10c5c0591c6c691feddef517396ef67f4b033a363406067f19803630e517d87a60bf541a01
+EBUILD libva-2.13.0-r2.ebuild 2202 BLAKE2B d192b08049c769382525fe7c6cd2679dcffdcbbec3db697fbf1d42fab21cfe63c81864edbaec1a0ee58004bcdb84f78fbfd9d3870db441359abe9dbcd4450ae2 SHA512 be154ae3722c3c53fe559a5975c99be093d483a8c14bd7473217e0dbe502078516024b5e04bc211b4d824680f1318143295a4d0b1c0d9ae0c8653110d2032f24
+EBUILD libva-9999.ebuild 2202 BLAKE2B 58fe8af2b0316bcd8000357b3c83b7d3175e266df6fd960e1c1ed4b708be6842d4c9d1deb0bf7b111c4c3e81655bbc0cc40cdaf6e62a1738a7fc0363d11280ee SHA512 469ea6356ede6915b61cfb82b26841904d702be7eabfae86f0ed2c7fe63fd9b626b89ffb6d273605a2ba3956ff91922d82660d1fa43c8464c5ab73ca2d9154ad
MISC metadata.xml 470 BLAKE2B d9df0ced571b8afa6cecda8dafb7165d142c3fd1c0fff21526d5624edb530e0ac705a36a7fa1a17d18583805a267652dfb77850a70aa47dcceb4794636821e9e SHA512 66f62980ed7d876f681bc77cb47cf43940fe056db6577557cf518604885c54ad94a17680c6749eb81937b44e21d7df9cad3ede05fdf74be88dcb6d21e271491e
diff --git a/x11-libs/libva/libva-2.13.0-r2.ebuild b/x11-libs/libva/libva-2.13.0-r2.ebuild
new file mode 100644
index 000000000000..fb840c456a59
--- /dev/null
+++ b/x11-libs/libva/libva-2.13.0-r2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal optfeature
+
+DESCRIPTION="Video Acceleration (VA) API for Linux"
+HOMEPAGE="https://01.org/linuxmedia/vaapi"
+
+if [[ ${PV} = *9999 ]] ; then
+ inherit git-r3
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="https://github.com/intel/libva"
+else
+ # SRC_URI="https://github.com/intel/libva/releases/download/${PV}/${P}.tar.bz2"
+ # The upstream provides periodically tarball with pre-built 'configure'.
+ # To simplify updates, portage use tarballs without pre-build 'configure'
+ # which are always available.
+ SRC_URI="https://github.com/intel/libva/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1)"
+IUSE="+drm opengl utils wayland X"
+
+RDEPEND="
+ >=x11-libs/libdrm-2.4.60[${MULTILIB_USEDEP}]
+ opengl? ( >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}] )
+ wayland? (
+ >=dev-libs/wayland-1.11[${MULTILIB_USEDEP}]
+ )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+PDEPEND="utils? ( media-video/libva-utils )"
+
+REQUIRED_USE="|| ( drm wayland X )
+ opengl? ( X )"
+
+DOCS=( NEWS )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/va/va_backend_glx.h
+ /usr/include/va/va_x11.h
+ /usr/include/va/va_dri2.h
+ /usr/include/va/va_dricommon.h
+ /usr/include/va/va_glx.h
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --with-drivers-path="${EPREFIX}/usr/$(get_libdir)/va/drivers"
+ $(use_enable opengl glx)
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable drm)
+ --enable-va-messaging
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}
+
+pkg_postinst() {
+ optfeature_header
+ optfeature "NVIDIA GPU support" x11-libs/libva-vdpau-driver
+ optfeature "Older Intel GPU support" x11-libs/libva-intel-driver
+ optfeature "Newer Intel GPU support" x11-libs/libva-intel-media-driver
+}
diff --git a/x11-libs/libva/libva-9999.ebuild b/x11-libs/libva/libva-9999.ebuild
index a5e8ebf286e2..8e84bcf7bb12 100644
--- a/x11-libs/libva/libva-9999.ebuild
+++ b/x11-libs/libva/libva-9999.ebuild
@@ -30,7 +30,6 @@ RDEPEND="
opengl? ( >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}] )
wayland? (
>=dev-libs/wayland-1.11[${MULTILIB_USEDEP}]
- dev-util/wayland-scanner[${MULTILIB_USEDEP}]
)
X? (
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
@@ -40,6 +39,7 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
BDEPEND="
+ dev-util/wayland-scanner
virtual/pkgconfig
"
PDEPEND="utils? ( media-video/libva-utils )"