summaryrefslogtreecommitdiff
path: root/x11-libs/libva/libva-2.14.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-16 07:52:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-16 07:52:23 +0100
commitc7c046a33897c533b949ee76326d620f5e07f2e9 (patch)
tree9cefb49f93bb8be42c9129fdf95d7ab846751826 /x11-libs/libva/libva-2.14.0.ebuild
parent6144cd2e90f8e3623912112050c8d2025de44f0a (diff)
gentoo auto-resync : 16:10:2022 - 07:52:23
Diffstat (limited to 'x11-libs/libva/libva-2.14.0.ebuild')
-rw-r--r--x11-libs/libva/libva-2.14.0.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/x11-libs/libva/libva-2.14.0.ebuild b/x11-libs/libva/libva-2.14.0.ebuild
deleted file mode 100644
index cfd96a8b8677..000000000000
--- a/x11-libs/libva/libva-2.14.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson-multilib optfeature
-
-DESCRIPTION="Video Acceleration (VA) API for Linux"
-HOMEPAGE="https://01.org/linuxmedia/vaapi"
-
-if [[ ${PV} = *9999 ]] ; then
- inherit git-r3
- EGIT_BRANCH=master
- EGIT_REPO_URI="https://github.com/intel/libva"
-else
- SRC_URI="https://github.com/intel/libva/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm64 ~loong ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="MIT"
-SLOT="0/$(ver_cut 1)"
-IUSE="+drm opengl wayland X"
-REQUIRED_USE="opengl? ( X )"
-
-RDEPEND="
- >=x11-libs/libdrm-2.4.60[${MULTILIB_USEDEP}]
- wayland? (
- >=dev-libs/wayland-1.11[${MULTILIB_USEDEP}]
- )
- X? (
- >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
- >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
- >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
- >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- wayland? ( dev-util/wayland-scanner )
- virtual/pkgconfig
-"
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/va/va_backend_glx.h
- /usr/include/va/va_x11.h
- /usr/include/va/va_dri2.h
- /usr/include/va/va_dricommon.h
- /usr/include/va/va_glx.h
-)
-
-multilib_src_configure() {
- local emesonargs=(
- -Ddriverdir="${EPREFIX}/usr/$(get_libdir)/va/drivers"
- -Ddisable_drm=false
- -Dwith_x11=$(usex X)
- -Dwith_glx=$(usex X)
- -Dwith_wayland=$(usex wayland)
- -Denable_docs=false
- -Denable_va_messaging=true
- )
- meson_src_configure
-}
-
-pkg_postinst() {
- optfeature_header
- optfeature "Older Intel GPU support" x11-libs/libva-intel-driver
- optfeature "Newer Intel GPU support" x11-libs/libva-intel-media-driver
-}