summaryrefslogtreecommitdiff
path: root/x11-libs/libva-compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /x11-libs/libva-compat
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'x11-libs/libva-compat')
-rw-r--r--x11-libs/libva-compat/Manifest1
-rw-r--r--x11-libs/libva-compat/libva-compat-1.8.3-r2.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/x11-libs/libva-compat/Manifest b/x11-libs/libva-compat/Manifest
index bebbc9ae90e1..0419cd76e3f1 100644
--- a/x11-libs/libva-compat/Manifest
+++ b/x11-libs/libva-compat/Manifest
@@ -1,3 +1,4 @@
DIST libva-1.8.3.tar.gz 186915 BLAKE2B 10713e3bd7aaefc033490fc9ef6485ec50774f274f09e9e06fd1479b882b221791375533a6826e5db9a758f2acd74f913a478da61fe32250a3e2d9c0062739fc SHA512 f2f360876d8443a22a3434aa1ac7ec5aa6d4b3cc1f13f475ef74e716f5937acc43e02f9a8b858b5b7b6539da3731f763843d45664cc19c70e81d8b87e93659ea
EBUILD libva-compat-1.8.3-r1.ebuild 1995 BLAKE2B 4c1ee367563e496bec8d4f1731690438adc1bd575e2799e3e672fa1ba40003adb829f263b31bbc9b41e4a4f071d1aed3dce475bebbe4f679da843aca4d952d4f SHA512 18ce41526f57cc1077f364ef1f04361adce4f218febd4e50c7345aacb4099414778dc88b9caa989fd6b1b51b0f5ace7caa8cc7f5706bd60b7ca8463aafd1d026
+EBUILD libva-compat-1.8.3-r2.ebuild 1723 BLAKE2B 080cbcf6ecff6e35ae3cbc6857baeeac2e1f07b561f80dfbe29d78334ce210d8c9f921650ef62151c0a4656ab136e637789c97770ac6b226594ece0ba5c80e62 SHA512 2e512fa85cbf929ef763abbdc082c4adeaf3b6da01e8f1136108242b617525937861c06b2c1a11ebb692408810e8a908724e748ddfd7feb3d4450b98b995f2b6
MISC metadata.xml 440 BLAKE2B e8071d75c17e53b38897201da353284933b04c5337f01404b2c80c6edf571d47b2e2b92f85451097aba5db421f5dca1a254d24425e096067c270b8aa0e732ae3 SHA512 eafd1feaee7adcd7903c26d9efd0cdadb118c2af683d3158a68a7f931eba83367d8702253b6ebfbea45001009f225a6b15f0cca8d8a2b303f757fb0d7d499541
diff --git a/x11-libs/libva-compat/libva-compat-1.8.3-r2.ebuild b/x11-libs/libva-compat/libva-compat-1.8.3-r2.ebuild
new file mode 100644
index 000000000000..af57dbec4262
--- /dev/null
+++ b/x11-libs/libva-compat/libva-compat-1.8.3-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal optfeature
+
+MY_PN="${PN%-compat}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Video Acceleration (VA) API for Linux"
+HOMEPAGE="https://01.org/linuxmedia/vaapi"
+SRC_URI="https://github.com/01org/libva/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+drm egl opengl wayland X"
+
+RDEPEND=">=x11-libs/libdrm-2.4.46[${MULTILIB_USEDEP}]
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ )
+ egl? ( >=media-libs/mesa-9.1.6[egl(+),${MULTILIB_USEDEP}] )
+ opengl? ( >=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )
+ !x11-libs/libva:0/0"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+REQUIRED_USE="|| ( drm wayland X )
+ opengl? ( X )"
+
+S="${WORKDIR}/${MY_P}"
+DOCS=( NEWS )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --with-drivers-path="${EPREFIX}/usr/$(get_libdir)/va/drivers"
+ $(use_enable opengl glx)
+ $(use_enable X x11)
+ $(use_enable wayland)
+ $(use_enable egl)
+ $(use_enable drm)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ emake -C va DESTDIR="${D}" install-libLTLIBRARIES
+ rm -vf "${ED}"/usr/$(get_libdir)/*.{la,so} || die
+}
+
+pkg_postinst() {
+ optfeature_header
+ optfeature "NVIDIA GPU support" x11-libs/libva-vdpau-driver
+ optfeature "Older Intel GPU support" x11-libs/libva-intel-driver
+ optfeature "Newer Intel GPU support" x11-libs/libva-intel-media-driver
+}