summaryrefslogtreecommitdiff
path: root/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild')
-rw-r--r--x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild
new file mode 100644
index 000000000000..4543af991c3e
--- /dev/null
+++ b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A system-wide notifications module for libtinynotify"
+HOMEPAGE="https://github.com/mgorny/libtinynotify-systemwide/"
+SRC_URI="https://github.com/mgorny/libtinynotify-systemwide/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="sys-process/procps:0=
+ x11-libs/libtinynotify:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+src_configure() {
+ local myconf=(
+ $(use_enable doc gtk-doc)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}