summaryrefslogtreecommitdiff
path: root/x11-libs/libnotify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /x11-libs/libnotify
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'x11-libs/libnotify')
-rw-r--r--x11-libs/libnotify/Manifest2
-rw-r--r--x11-libs/libnotify/libnotify-0.7.8.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/x11-libs/libnotify/Manifest b/x11-libs/libnotify/Manifest
index 28886c6327cf..9bcd82af1f78 100644
--- a/x11-libs/libnotify/Manifest
+++ b/x11-libs/libnotify/Manifest
@@ -1,3 +1,5 @@
DIST libnotify-0.7.7.tar.xz 285356 BLAKE2B ace0eedb1beecfbb89726960e441821d64f5ac456dfc6294b051479078726aed6fbacbd1e8cb17578933adbc4c94711b0d69a292778ba4bce096552a5197722b SHA512 133874114407bf12267ef609f5941657181760bc7cf115c5973b1810cb72bf55072b621c143e32be1e7e8b49f244851925d14bc3f9f26457747b8a8695ee9954
+DIST libnotify-0.7.8.tar.xz 108436 BLAKE2B 0a73eabe58faca55e16774cda6f649ab3187bd73a1f87b538d5098f390571a6a34078883dbd2447731d6e4cae315d8286e9e8acc06e85590c8b05a693a83e7f7 SHA512 9973d7a1af5dd7cfbaa0d0d2c9e72a40df9d814967fde47e95763a69690cc4ed32ecf713d75f91f3dff99a693eff9dab963be124e0530ebf231d517a44e75e94
EBUILD libnotify-0.7.7-r1.ebuild 1513 BLAKE2B 89fb44f85bbe8f928ece85952fc8c9a8e34690f8df7d6f241b2c8db9347c9d14d51aa063753a9b0535bd768a4aa9f8f2e0dbcccb38357bdf4541ef18c32439dc SHA512 ae9cdf1c771c51ef00bbbe750be45b92d571526a8aee568aedb62e8b9de4f6a7343d092554c078ceea0f127649105c22832f62d7e20c4a3273cc7acebab49fd2
+EBUILD libnotify-0.7.8.ebuild 1384 BLAKE2B 73af3c2f90aa1622c129f989a917f068de916747ed484d3a828386d147eb0c8fa711abdd59f72e5a7a28bdf94970fdb7f8b3195a974143236f3daefc03bc2fd6 SHA512 f3cf46429083c857de5be24898f6da633424b87f3c969bae06ff56cffce94153fdeef3a835c6b8534a687ab350bddbf989731e8afd2ccaa76c81a207d66ce081
MISC metadata.xml 276 BLAKE2B 889856a4e8b234e03eb27d32a4bce748a561f98ca0faa36de124e58e3832d804d1492f59db1154c4ec0e2e0e46c7d9cf38d9911ee83dd0863699581000610f31 SHA512 673180ba375ea401c0a8f197d516417b3f9361b11943c71bac88b0d0b1407b0bc657f5763c6fb6e429cc6ee112869a2247083fe56743e9ce918855c0ea929e59
diff --git a/x11-libs/libnotify/libnotify-0.7.8.ebuild b/x11-libs/libnotify/libnotify-0.7.8.ebuild
new file mode 100644
index 000000000000..ff9add88c106
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.7.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson multilib-minimal xdg-utils
+
+DESCRIPTION="A library for sending desktop notifications"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libnotify"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="+introspection test"
+
+RDEPEND="
+ app-eselect/eselect-notify-send
+ >=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-libs/gobject-introspection-common-1.32
+ dev-util/glib-utils
+ virtual/pkgconfig
+ test? ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )
+"
+PDEPEND="virtual/notification-daemon"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dtests="$(usex test true false)"
+ -Dintrospection="$(multilib_native_usex introspection enabled disabled)"
+ -Dgtk_doc=false
+ -Ddocbook_docs=disabled
+ )
+ meson_src_configure
+}
+
+multilib_src_install() {
+ meson_src_install
+
+ mv "${ED}"/usr/bin/{,libnotify-}notify-send || die #379941
+}
+
+pkg_postinst() {
+ eselect notify-send update ifunset
+}
+
+pkg_postrm() {
+ eselect notify-send update ifunset
+}