summaryrefslogtreecommitdiff
path: root/x11-libs/libnotify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-17 02:30:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-17 02:30:06 +0100
commita6266c63b23ed0ee16865627ca53e4f5353f0a5c (patch)
tree6ed71ecc485e9c4903818db305f6ebee454a38db /x11-libs/libnotify
parent1fd4e372381e1318aae1b7d3338c04156e5da974 (diff)
gentoo auto-resync : 17:07:2022 - 02:30:06
Diffstat (limited to 'x11-libs/libnotify')
-rw-r--r--x11-libs/libnotify/Manifest2
-rw-r--r--x11-libs/libnotify/libnotify-0.8.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-libs/libnotify/Manifest b/x11-libs/libnotify/Manifest
index a4c27797a3a3..8696e82c12fa 100644
--- a/x11-libs/libnotify/Manifest
+++ b/x11-libs/libnotify/Manifest
@@ -1,5 +1,7 @@
DIST libnotify-0.7.12.tar.xz 102032 BLAKE2B fc0c0f377bf86cb9a7d3e080cf0aa23fa287a9199656d403624925208d86390e96f62d4c41f4b457efd403139f1bad52ff5fdd2c0cb3270c0abc82957b2634cf SHA512 1ddbdc2ea7ba653ea54169db9ed3d471f6e3421ef29e486c9b8d36837a655bcd613d0f07a8cf1253b87c42a2651e2f1634145622d8624d91e4223452deb99f1b
DIST libnotify-0.7.9.tar.xz 98148 BLAKE2B 4728d00a204cd1003e8171a54c23bb975c0477c245c1175558f27555763113ec8bd7abd7ef81f6bad2b98604efe436d843958e77473436e68560775804473383 SHA512 8a842b50777279efdb7d96a836a546c47decad158a4f03f7ffc818860d1f6276a657619e4f4a19a4e2f5ad55e0371c793420d50d802983700e8c342273b73874
+DIST libnotify-0.8.0.tar.xz 105288 BLAKE2B fc1897896d0f0d1bc13c63717ea050eb05da98979257970d57f780b9602b43b3449211424ee5e116eae957438ccb43a3dfa78935eeca9bc27a729be9e2b4e804 SHA512 17fc2e8bb9a61560e796b9e4258ebb56e303e285fa0c5a58f5dbddc0a5493e6f8474d24c1f0a34178810385e9f1d33ddba027b9c0f4364d83ddb57d4f5d78f56
EBUILD libnotify-0.7.12.ebuild 1498 BLAKE2B 00935df8d40a20d80d1bc1c5bd226d1670aa6b858b235f888a30be4516c3f3ac83f60bf3bc53daf707c1b13d3506bb3bc50d6b6e6b1752ad8e57d86613f941c9 SHA512 9a8e33fb1dfbfd7e8649a9567fb121b61d043c344dd153795d58bb1b0ae16aa45f9559d97f0b0f6ff218a6889c91b4d79aaeabe20e130ccac71e02389d1dfab7
EBUILD libnotify-0.7.9-r1.ebuild 1486 BLAKE2B eb83500e64f278f7a471afd536cb873c23110a6f1f8c8e1d8d59acbea6c36a8b8494327e9582658dee57055f18c60a898388cad29573fb82e1a28f6e7d0e18f7 SHA512 dc4fbdea0c1cd7ca153638b3a643e23c66bb32ad504c7cb3a74c49f1af48ddc6536c14d9a52c440399a9ec6bee3703a156cbb12bda91dc8aa53dd46c57ef4752
+EBUILD libnotify-0.8.0.ebuild 1500 BLAKE2B 3747334af0b8478e87104d6efff0ddce488e689e53dd22f4c2d7d0a5c148765340314de481e4c9510d4293438b7e21569bd8b4fae97c646e37107f4768c4c68e SHA512 f9f5156ab3cbd01b050d3327a6922fb7b3203f4bc09ba9ea0e8f0124aeaa7e3bd217d51bbf80e1ad4a27ee1f9eb75475dda6eed03fdc71492d0e7603065a1874
MISC metadata.xml 397 BLAKE2B ed17366f7a815c49a838fef999ccf115e109a3ed9eb88d527e464c49692abca943f8c8971f2a263012cb12c2c1426b3747b733cc8c20926ff0139446b1c6e685 SHA512 89e5213048893402d277dd137d4236164d0cd47cc6e5208bade85cc67303f0d754259a5ccee789e2b5e77aae2188baa09f631e5ed1a0e216215bd091539cc0be
diff --git a/x11-libs/libnotify/libnotify-0.8.0.ebuild b/x11-libs/libnotify/libnotify-0.8.0.ebuild
new file mode 100644
index 000000000000..f91fcaa55488
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.8.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson-multilib xdg-utils
+
+DESCRIPTION="A library for sending desktop notifications"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libnotify"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="gtk-doc +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-libs/gobject-introspection-common-1.32
+ dev-util/glib-utils
+ virtual/pkgconfig
+ app-text/docbook-xsl-ns-stylesheets
+ dev-libs/libxslt
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.1.2 )
+ test? ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )
+"
+IDEPEND="app-eselect/eselect-notify-send"
+PDEPEND="virtual/notification-daemon"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ $(meson_native_use_feature introspection)
+ $(meson_native_use_bool gtk-doc gtk_doc)
+ -Ddocbook_docs=disabled
+ )
+ meson_src_configure
+}
+
+multilib_src_install() {
+ meson_src_install
+
+ mv "${ED}"/usr/bin/{,libnotify-}notify-send || die #379941
+}
+
+pkg_postinst() {
+ eselect notify-send update ifunset
+}
+
+pkg_postrm() {
+ eselect notify-send update ifunset
+}